Access - Macro no se ejecuta

   
Vista:

Macro no se ejecuta

Publicado por Macro no se ejecuta (2 intervenciones) el 13/11/2008 02:16:09
Hola tengo un problema estoy trabajando con macros y soy un poco novata, la macro tiene lo siguiente:

Condición Acción
Eco
Abri Formulario
Buscar Registro
[Formularios]![Cursos tabular]![Nombre curso]="Internet" Establecer Valor
Y [Formularios]![Cursos tabular]![Nºhoras]<400
... Establecer Valor
... Cerrar
... Cuadro Msj
.... Detener Macro
Cuadro Msj
Cerrar
Eco

Lo cieto es que las opciones que llevan ... no las hace y quiero saber la razón, solo ejecuta la primera opción que tiene condición y salta a las que no tienen puntos suspensivos..
Alguien ayudeme por favor además sale al lado de cada fila un simbolito de aviso que es como un triangulo amarillo. En realidad soy novata en esto asi que agradeceria su ayuda
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Macro no se ejecuta

Publicado por Pepe (766 intervenciones) el 13/11/2008 11:07:41
Haber si soy capaz de aclarate algo

Los tres puntitos (...) en la columna de condición, lo que hacen es repetir la condición que figure en la línea anterior.

Osea que si tienes una linea con una condición para que se ejecute una acción, si pones tres puntos en la columna "condición" de la línea de abajo, es como si volvieses a escribir la condición.

Pepe
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Macro no se ejecuta

Publicado por Rossana (2 intervenciones) el 15/11/2008 03:08:41
Si eso lo se, pero quiero saber ¿por que si la condicion se repite para todas las filas que tienen puntos suspensivos? solo me ejecuta la primera acción que tiene condición y omite el resto ??
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Macro no se ejecuta

Publicado por Pepe (766 intervenciones) el 15/11/2008 10:55:12
Hola Rossana

Viendo la macro que ponias, entiendo que la condición que pones es :
[nombre curso] y [nº horas]

- Con esa condición tienes dos acciones de establecer valor
- Luego tienes una acción de "cerrar" ¿no cerraras el formulario en el que basas la condición?. Si es así, deberías de quitar la condición de hay hasta el final.

Saludos, Pepe
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Macro no se ejecuta

Publicado por Rossana (1 intervención) el 15/11/2008 22:17:24
Si pero el problema es que la segunda condicion de establecer valor no la hace ni nada de lo que siguie por que??
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Macro no se ejecuta

Publicado por Pepe (766 intervenciones) el 16/11/2008 10:48:57
Hola Rossana

Mirando lo que expusiste en tu primer mensaje no lo veo. Si quieres, mandame al correo la macro y la doy un vistazo.

Si lo haces, la versión que tengo es la 2000

Pepe
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar