Access - Problema con consulta

   
Vista:

Problema con consulta

Publicado por Leandro (92 intervenciones) el 09/12/2008 12:37:41
Buenos dias ,mi problema es el soguienmte quiero hacer un form con un txt que me pida un nº si esta me cierre ese form y me abra otro form y sino esta que me saque un msg y cierre , yo le he puesto el codigo siguiente pero me da error de sintaxix :

Dim polisse as string
polisse = Nz(dookup ("npolisse","Fvpolisses","npolisse = '" & Me.polisse & " ' "),"")
If polisse = "" then
Msgbox ("no existe poliza")
else
DoCmd openform "Consultapolisses"
end if
Decirme si es correcto lo que he escrito gracias .
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problema con consulta

Publicado por Wilmer Velasquez (1 intervención) el 09/12/2008 18:09:03
No no es correcto esta todo malo !!!

Y ESTO QUE ES UN FUNCION O QUE

Nz(dookup(
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con consulta

Publicado por Leandro (92 intervenciones) el 09/12/2008 18:46:47
Buenas , parece que me he equivocado lo correcto es la funcion Dlookup, le escribi anteriormente mal , pero el resto tampoco es correcto ?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con consulta

Publicado por quique (293 intervenciones) el 09/12/2008 19:06:17
dice:

DoCmd openform "Consultapolisses"

debe decir:

DoCmd.openform "Consultapolisses" (falta un punto)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con consulta

Publicado por Leandro (92 intervenciones) el 09/12/2008 19:43:26
Hola Quique , lo que dices es correcto va con punto , pero no me sale el registro que le he dado el txt , sino el primer registro de la tabla , si lo pongo como he escrito, gracias.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con consulta

Publicado por QUIQUE (293 intervenciones) el 10/12/2008 13:36:29
A VER LEANDRO SI ESTO TE SIRVE.

CREAS UN BOTON "BUSCAR"
y un segundo formulario con origen en la tabla donde estan los datos
que buscas al que llamaremos "frm2"

Private Sub buscar_Click()

If txt1 <> "" Then
Me.RecordSource = "select * from '"MI BASE DE DATOS" where '"CAMPO" Like ' " & txt1 & " ' "

End If
If Me.RecordsetClone.RecordCount = 0 Then

MsgBox "NO SE ENCONTRÓ EL Nº BUSCADO", vbOKOnly, "AVISO"
txt1.SetFocus
End If

If Me.RecordsetClone.RecordCount >= 1 Then

(con esto que sigue logras que se abra en el Nº que buscas)
Dim stDocName As String
Dim stLinkCriteria As String

stDocName = "frm2"

stLinkCriteria = "[CAMPO]=" & Me![CAMPO] (aqui van los campos coincidentes)
DoCmd.OpenForm stDocName, , , stLinkCriteria, acFormEdit

End If


End Sub

ESPERO QUE TE SIRVA

QUIQUE
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con consulta

Publicado por Leandro (92 intervenciones) el 10/12/2008 17:11:11
Buenas Quique en la linea de Me.recordsource me da error de compilacion ,error de sintaxix yo he escrito lo siguiente
Me.recorsource = "Select * from ' "Fvpolisses" where ' " Npolisse" like ' " & polisse & " ' "
Gracias , un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con consulta

Publicado por quique (293 intervenciones) el 10/12/2008 18:48:38
dice:
Me.recorsource = "Select * from ' "Fvpolisses"
where ' " Npolisse" like ' " & polisse & " ' "

debe decir si el campo es numérico:

Me.recorsource = "Select * from Fvpolisses where Npolisse like '" & polisse & "'"

debe decir si el campo es texto:

Me.recorsource = "Select * from Fvpolisses where Npolisse like '*" & polisse & "*' "

Mira bien las caracteristicas del campo por el cual buscas, pues ya sebes que la consulta debe escribirse de distinto modo.
Segun sea tu campo copia y pega el código.
A ver si ahora anda.

quique
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con consulta

Publicado por Leandro (92 intervenciones) el 10/12/2008 19:13:37
Quique perfecto ahora ya pasa ese punto , entones cuando le dio el nº si no esta me sale el mensaje , pero se ve que si coincede no hace nada se me queda en el botob de buscar
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con consulta

Publicado por Leandro (92 intervenciones) el 10/12/2008 19:29:01
Quique mirando lo escrito por ti el codigo de coincidencia es este
StlinkCriteria = "[Npolisse] = & Me![polisse]
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con consulta

Publicado por quique (293 intervenciones) el 11/12/2008 13:45:50
REALMENTE ME CUESTA UN POQUITO SEGUIR EL HILO DE ESTE POST PORQUE ESTOY TIRANDO EN LA OSCURIDAD.
DESCONOZCO CUALES SON LAS PROPIEDADES DE LOS CAMPOS, COMO ESTAN RELACIONADAS LAS TABLAS , Y TAMPOCO SE QUE ACCESS ESTAS USANDO.
ME RESULTARIA MÁS SENCILLO SI ME ENVIAS LA BASE A MI MAIL CON UNA NO TA QUE EXPLIQUE EXACTAMENTE LO QUE QUERES HACER . NO HACEN FALTA TODOS LOS DATOS CON 9 O 10 ESTARIA BIEN.
LUEGO CUANDO TE LA REENVIE PODRÁS VER EL CÓDIO Y LAS FUNCIONES QUE COLOQUE. OK.
QUIQUE
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con consulta

Publicado por Leandro (92 intervenciones) el 12/12/2008 14:58:05
Buenas Quique , como tu me recomiendas te he hecho una copia de la BD y te la he enviado a tu correo , ya me diras si ha llegado correctamente, saludos .
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problema con consulta

Publicado por quique (293 intervenciones) el 12/12/2008 19:54:48
acabo de recibirla y ya comienzo a verla

quique
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar