Access - Problemas con Campo Si/No

   
Vista:

Problemas con Campo Si/No

Publicado por Juan (4 intervenciones) el 26/01/2011 13:02:50
Hola,

Tengo un problema con los campos Si/No cuando quiero filtrar para que me queden los que NO estan tildados... cual seria el criterio que deberia poner en la consulta?
Porque cuando pongo Si me los filtra perfecto, pero cuando pongo No me pone error de sintaxis.

Desde Ya Muchas Gracias.

Juan
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problemas con Campo Si/No

Publicado por Marcelo (161 intervenciones) el 26/01/2011 15:24:50
- Sí (S mayúscula, í con acento) = -1 = Activado = Verdadero

- No = 0 = Desactivado = Falso

Te recomiendo usar -1 y 0 respectivamente cómo criterio de un filtro, consulta o expresión. Siempre es mejor usar números, son menos ambiguos que el texto, son números del tipo boolean (álgebra de Bool, relacionada con lógica matemática), tambien llamados flag (bandera en inglés).

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con Campo Si/No

Publicado por Juan (4 intervenciones) el 26/01/2011 16:03:09
GRACIAS MARCELO!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Problemas con Campo Si/No

Publicado por Marcelo (161 intervenciones) el 27/01/2011 21:49:24
De nada, un saludo desde Viña del Mar (Valparaíso), Chile
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar