Access - Problemas con el PATH de las referencias

   
Vista:

Problemas con el PATH de las referencias

Publicado por Jordi (6 intervenciones) el 10/02/2011 23:48:38
Hola a todos.

En mi empresa trabajamos con una base de datos en Access97 y me he encontrado problemas con los informes en los PC con Windows7.

El problema que tengo al mostrar informes es por ejemplo: en un campo de texto con "=recortar([Campo]&" euros") aparece en el informe NOMBRE?.

He mirado las referencias y esto es lo que he observado (Nota: pongo solo una referencia, a modo de ejemplo):

WindowsXP (Funciona OK): C:\Archivos de programa\Archivos comunes\Microsoft Shared\VBA\VBA332.DLL

Windows7 (Errores): C:\Program Files\Common Files\Microsoft Shared\VBA\VBA332.DLL

El caso, como veis, es que en Windows7 la ruta está en Inglés y en WindowsXP en español.

En los equipos que tienen Windows7, si actualizo las referencias, poniendo la ruta en inglés funciona correctamente. Por lo que deduzco que el problema es el idioma del PATH.

El problema lo tengo, al modificar la base de datos, y al hacer la copia a cada ordenados, los equipos con windows7 vuelven a fallar.

Por todo esto, quisiera saber si alguien sabe algún código o manera de que el Access detecte el path correcto, en función de el sistema operativo, o algo similar.

Por favor, en caso de ser así, me podrías dar el ejemplo concreto con la referencia que he indicado al principio?

Añado todas las referencias de la BD.

C:\Archivos de programa\Archivos comunes\Microsoft Shared\VBA\VBA332.DLL

C:\Archivos de programa\Microsoft Office\Office\MSACC8.OLB

C:\Archivos de programa\Archivos comunes\Microsoft Shared\DAO\DAO350.DLL

C:\BD\Comunes\BDSoporte.mde

C:\Archivos de programa\Microsoft Office\Office\MSO97.DLL

C:\BD\Comunes\barcodex.ocx


Muchas gracias anticipadas.

Jordi
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Problemas con el PATH de las referencias

Publicado por Jordi (6 intervenciones) el 11/02/2011 11:18:06
Hola.

No se muy bien como, pero vi que una de las referencias, tenía una ruta equivocada, la he corregido y compilado de nuevo. La referencia en concreto era "barcodex.ocx".

Luego en los equipos con windows7 la he registrado y todo OK.

Saludos.

Jordi
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar