Access - #Error al imprimir cuadro de texto

   
Vista:

#Error al imprimir cuadro de texto

Publicado por Cristian (42 intervenciones) el 23/05/2017 19:29:18
Hola, tengo un informe que contiene 4 subinformes, 2 de ingresos y 2 de egresos, cada subinforme tiene su suma.
Al final del informe principal muestro en un cuadro de texto la suma de los 2 ingresos y en otro cuadro de texto la suma de los 2 egreso. En un tercer cuadro de texto muestro el saldo anterior y en un cuarto cuadro de texto muestro el saldo, es decir, (ingresos - egresos + saldo anterior).
Abro el informe y todo bien, los valores son correctos y cuando le hago clic en imprimir o boton derecho vista preliminar los cuadros de textos me muestra #ERROR.

Podran decirme en que le estoy errando? Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Norberto

#Error al imprimir cuadro de texto

Publicado por Norberto (509 intervenciones) el 25/05/2017 16:06:44
Hola.

¿Podrías indicar dónde están y qué expresiones tienen los cuadros de texto de los subinformes que contienen los totales y las expresiones de los cuadros de texto del informe principal que dan el error?

Un saludo,

Norberto.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

#Error al imprimir cuadro de texto

Publicado por Cristian (42 intervenciones) el 19/06/2017 20:54:54
Hola disculpas por la demora.
Los subinformes tienen un cuadro de texto independiente que suma el valor, con la exprexion =SUMA([Importe]), y el principal tiene un cuadro de texto con la expresion
Entradas
=[factura Consulta].[Informe]![AccessTotalsTotal]+[ING_VS Consulta].[Informe]![AccessTotalsIMPORTE]
Salidas
=[Pagos Consulta].[Informe]![AccessTotalsTotal]+[EGR_VS Consulta].[Informe]![AccessTotalsIMPORTE]

Total
=[Entradas]-[Salidas]+[SaldoAnterior]

El tema es que aveces alguno de los subinformes no tiene datos, en pantalla todo bien porque muestra el valor 0 pero al hacer vista preliminar me muestra #Error, por lo que vi y ya probe y no me funciono es que arrastra el valor NULL y por eso provoca el error
Probe con NZ([(factura Consulta].[Informe]![AccessTotalsTotal]+[ING_VS Consulta].[Informe]![AccessTotalsIMPORTE]),0) y no me funciono, probe con siimn(iserror([factura Consulta].[Informe]![AccessTotalsTotal]+[ING_VS Consulta].[Informe]![AccessTotalsIMPORTE]), 0,([factura Consulta].[Informe]![AccessTotalsTotal]+[ING_VS Consulta].[Informe]![AccessTotalsIMPORTE])) y tampoco funciono.

Agradezco la ayuda.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar