Algoritmia - programacion y algoritmo

   
Vista:

programacion y algoritmo

Publicado por nilson camilo (3 intervenciones) el 14/09/2009 20:37:10
1lea dos numeros enteros y determina si son mayores a cero
2lea un numero y defina si es multiplo de cinco
3 lea un numero y dina si su cubo es multiplo de tres
4 lea dos numero y defina cual es el mayor y cual es el menor
5lea dos numeros y multipliquelos si el segundo es negativo si no sumelos

por favor colaborarme con esto apenas estoy empezando gracias o dar ejemplos como resuelvo esto gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Algoritmia
- Cursos de Algoritmia
- Temas de Algoritmia
- Chat de Algoritmia
información
Cursos y Temas de Algoritmia
- Estructuras de datos
- Algoritimia: La Recursividad
- Recursividad

RE:programacion y algoritmo

Publicado por nilson camilo (3 intervenciones) el 14/09/2009 20:48:42
por favor cualquiera que es viendo este mensaje ayudeme gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:programacion y algoritmo

Publicado por eduardo (55 intervenciones) el 15/09/2009 14:45:55
1)
Var
Entero: a, b

Inicio
Leer( a, b )
Si ( a > 0 y b > 0 ) Entonces
Escribir( "Ambos son mayores a cero" )
Sino
Escribir( "Por lo menos uno de ellos no es mayor a cero" )
Fin si
Fin

2)
Var
Entero: numero

Inicio
Leer( numero )
Si ( numero mod 5 == 0 ) Entonces
Escribir( "Es múltiplo de 5" )
Sino
Escribir( "No es múltiplo de 5" )
Fin si
Fin

3)
Var
Entero: num, cubo

Inicio
Leer( num )
cubo = num * num * num
Si ( cubo % 3 == 0 ) Entonces
Escribir( "Su cubo es múltiplo de 3" )
Else
Escribir( "Su cubo no es múltiplo de 3" )
Fin si
Fin

4)
Var
Entero: a, b, mayor, menor

Inicio
Leer( a, b )
Si ( a != b ) Entonces
mayor = a > b ? a : b /* operador ternario de C/C++ */
menor = a < b ? a : b
Escribir( "Mayor = " + mayor + "Menor: " + menor )
Sino
Escribir( "Ambos son iguales" )
Fin si
Fin

5)
Var
Entero: a, b, resultado

Inicio
Leer( a, b )
Si ( b < 0 ) Entonces
resultado = a * b
Sino
resultado = a + b
Fin si
Escribir( "Resultado: " + resultado )
Fin
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar