Algoritmia - necesito hacer pseudocodigos y diagramas de flujo

   
Vista:

necesito hacer pseudocodigos y diagramas de flujo

Publicado por lupita (1 intervención) el 11/11/2009 02:38:18
Necesito hacer pseudocodigo y diagrama de flujo para los siguientes problemas:

1. Determinar cuantos hombres y mujeres se encuentran en un grupo N.
2. Encontrar la suma de los cuadrados de los enteros del 1 al N.
3. Realizar la multiplicación de dos números utilizando el método de sumas sucesivas.

Por favor, voy empezando mi carrera en informatica y es a distancia así que no tengo maestro, me está costando mucho trabajo lo de la sintaxis y los símbolos, ayudaaaaaa.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:necesito hacer pseudocodigos y diagramas de flu

Publicado por osvaldo (1 intervención) el 13/11/2009 19:38:21
mira.... tengo ahorita algunos algoritmos parecidos ... y pues espero que te sirvan solo tienes que utilizar tu logica para poder modificarlos atus requerimientos... solo rebisalos va... saludos y espero que te ayan servido y si tienes dudas te dejo mi msn ahi me puedes contactar: osvaldo.240@hotmail.com

1. Un maestro desea saber qué porcentaje de hombres y que porcentajes de mujeres hay en un grupo de estudiantes.
Entrada: Numero total de estudiantes, cuantos hombres y cuantas mujeres.
Salida: Porcentaje de hombres y mujeres
INICIO
Declarar (E, H, W, PH, PM: REAL)
Escribir (“Algoritmo para calcular el porcentaje de hombre y mujeres en un grupo de estudiantes” \n”)
Escribir (“Introduce el numero de estudiantes en el grupo”)
Leer (E)
Escribir (“Introduce el numero de hombre en el grupo”)
Leer (H)
Escribir (“Introduce el numero de mujeres en el grupo”)
Leer (M)
W←E/100
PH←H/W
PM←M/W
Escribir (“El porcentaje de hombres en el grupo es de: “, PH, “\n”)
Escribir (“El porcentaje de mujeres en el grupo es de: “, PM)
FIN


2. Leer un número entero y escribir el valor absoluto del mismo.
Entrada: Un número entero
Salida: Valor absoluto
inico
Declarar (N, NN, NNN : ENTERO)
Escribir: (“Algoritmo para obtener el valor absoluto de un numero entero \n”)
Escribir (“Ingresar un numero entero”)
Leer(N)
NN←N^2
NNN←NN^0.5
Escribir (“El valor absoluto del numero es de: “,NNN)
FIN

y con respecto al 3° ejercico es muy sencilllo soloo tienes que tener una serie de varibles las cuales tienen tienen un valor ... y ps como comentas en tu post las sumas sucesivas son aqueelllas que tiene un orden de suma aver como te explico .... ejemplo:
T←5+1
TT←T+2
R←TT+90
entonces desimos que el numero guardado en la varibble T es 6 y que T+2 se guarda en TT con un valor de 8, entonces en R se guarda con el valor de 98 puesto que si TT vale 8; seria 8+90 =98.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:necesito hacer pseudocodigos y diagramas de flu

Publicado por roberto (1 intervención) el 05/03/2010 02:33:34
que significa W??
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:necesito hacer pseudocodigos y diagramas de flu

Publicado por julian alvarado (2 intervenciones) el 08/03/2010 03:27:25
mira creo q va asi:
1.inicio
acumm=0, sexo, n
x=1
acumf=0
mientras que (x<=n) hace
lee sexo
si(sexo="masculino")
acumm=acumm+1
sino
acumf=acumf+1
x=x+1
fin mientras
imprimir "hay",acumm,"hombres y",acumf,"mujeres"
fin
2.inicio
acum=o
s=0
x=1
lee n
mientras que(x<=n)hacer
s=x*x
acum=acum+s
x=x+1
fin mientras
imprimir acum
fin
3.inicio
x=0
lee num1,num2
mientras que(x<num2)hacer
s=num1+x
x=s
fin mientras
imprimir x
fin
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar