Algoritmia - Algoritmos

   
Vista:

Algoritmos

Publicado por Gabriel (2 intervenciones) el 09/04/2011 01:34:22
- Dados "n" numeros, calcular la sumatoria de los impares y promedio de los pares.
- Decir si un numero es perfecto. Un numero es perfecto cuando la suma de sus divisores excepto el mismo es igual al propio numero. Por Ejemplo, el numero 6 es perfecto, pues sus divisores son 1,2 y 3. Y la suma de estos divisores da 6, es decir el mismo numero.
- Un vendedor ha realizado una serie de ventas y desea conocer aquellas por valor $200 o menos, las mayores a $200 pero menores a $400 y el numero de ventas de $400 o superiores.
- Calcular y mostrar la sucesión de ULAM. La sucesión de ULAM en honor al matematico S. Ulam, consiste en:
*comience con cualquier numero entero positivo.
*si el numero es par, dividalo entre 2. Si es impar, multipliquelo por 3 y sumele 1.
*obtenga enteros sucesivamente repitiendo el proceso hasta que el numero obtenido en la sucesion sea 1.
Por ejemplo cuando el entero inicial es 26, la secuencia será: 26,13,40,20,10,5,16,8,4,2,1.
- Calcular y mostrar los "n" primeros terminos de la Serie Fibonacci. Recuerde que los dos primeros términos de esta serie siempre son 0 y 1. A partir del tercer término, se calculan sumando los dos anteriores. Por Ejemplo si se desea conocer los 8 primeros términos de la serie, el programa debe mostrar: 0,1,1,2,3,5,8,13.
- Suponga en que una reciente eleccion hubo cuatro candidatos, identificados como A,B,C, y D. Se necesita saber el número de votos que obtuvo cada candidato y el porcentaje respecto al total de votantes. El programa terminará cuando se digite como nombre del candidato una letra diferente.
- Una empresa necesita saber cuál es el empleado que tiene mayor sueldo.
- Calcular lo que hay que pagar por una serie de llamadas telefonicas. Por cada llamada, se necesita saber el tipo (Internacional, Nacional o Local), y la duracion en minutos. El criterio que se sigue para calcular el costo de cada llamada es el siguiente:
*Internacional: 3 primeros minutos se cobran a $7.59
Cada minuto adicional a $3.03
*Nacional: 3 primeros minutos se cobran a $1.20
Cada minuto adicional a $0.48
*Local: Las primeras 50 llamadas no se cobran. Luego cada llamada cuesta $0.60
- Se dice que un entero positivo N es un numero Primo si los únicos enteros positivos que lo dividen son exactamente 1 y el mismo numero (N). Obtenga y cuente todos los numeros primeros menores a M.

Si me pueden ayudar porfavor.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Henry

Algoritmos

Publicado por Henry (5 intervenciones) el 12/04/2011 05:08:22
Buenas noches Gabriel.
Son muchos algoritmos, para cuando los quieres. Que estas estudiando. Que tipo de algoritmo quieres( Standar, seudocodigo, etc. )
Este es el 1ro. Tipo standar:

Declarar opcion=no, numero,cociente,resto,cont,pares,impar,promedio_pares
Hacer Mientras opcion="no"
leer numero
cociente=numero/2
mover residuo->resto
Si resto=0 entonces
pares=pares+numero
cont=cont+1
De lo contario
impar=impar+numero
Fin si
Mensaje¿Desea salir si/no?
leer opcion
Fin Hacer Mientras
promedio_pares=pares/cont
Escribir promedio_pares, impar
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Henry

Algoritmos

Publicado por Henry (5 intervenciones) el 13/04/2011 02:40:29
* Ventas diarias 20 dias habiles

Declarar dia=1,ventas,V200,Vmenor400,Vmay_igual400
Hacer mientras dia<=20
leer ventas
Si ventas<=200 entonces
V200=V200+1
De lo contrario
Si ventas<400 entonces
Vmenor400=Vmenor400+1
De lo contrario
Vmay_igual400=Vmay_igual400+1
Fin Si
Fin Si
dia=dia+1
Fin Hacer mientras
Mostrar V200,Vmenor400,Vmay_igual400
------------------------------------------------------------------------------------------
* Sucesión de ULAM

Declarar numero,cociente,resto
leer numero
Hacer mientras numero>0
cociente=numero/2
mover residuo->resto
Si resto=0 entonces
numero=numero/2
De lo contrario
numero=numero*3+1
Fin Si
Mostrar numero
Si numero=1 entonces
numero=0
Fin Si
Fin Hacer mientras
------------------------------------------------------------------------------------------
* Elección de candidatos

Declarar voto, voto_A,voto_B,voto_C,voto_D,total,A%,B%,C%,D%
leer voto
Hacer mientras voto=A O voto=B O voto=C O voto=D
Si voto=A entonces
voto_A=voto_A+1
Fin Si
Si voto=B entonces
voto_B=voto_B+1
Fin Si
Si voto=C entonces
voto_C=voto_C+1
Fin Si
Si voto=D entonces
voto_D=voto_D+1
Fin Si
leer voto
Fin Hacer mientras
total=voto_A+voto_B+voto_C+voto_D
A%=voto_A*100/total
B%=voto_B*100/total
C%=voto_C*100/total
D%=voto_D*100/total
Mostrar total,voto_A,A%,voto_B,B%,voto_C,C%,voto_D,D%
-------------------------------------------------------------------------------------------

* Determinar el empleado con mayor sueldo, se leen 20 empleados

Declarar sueldo,cedula_id,sueldo_mayor=0,cedula_id_empl,contador=1
Hacer mientras contador<=20
leer cedula_id,sueldo
Si sueldo>=sueldo_mayor entonces
sueldo_mayor=sueldo
cedula_id_empl=cedula_id
Fin Si
contador=contador+1
Fin Hacer mientras
Mostrar cedula_id_empl,sueldo_mayor
------------------------------------------------------------------------------------------
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Algoritmos

Publicado por Gabriel (2 intervenciones) el 14/04/2011 03:47:05
Sería si es posible en pseudocodigo, se los agradecería.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar