Algoritmia - Algoritmo primeros N numeros perfectos

   
Vista:

Algoritmo primeros N numeros perfectos

Publicado por majo (1 intervención) el 01/05/2013 17:28:19
Hola, necesito ayuda para realizar este algoritmo:
Un numero perfecto es aquel que es igual a la suma de los divisores menores que el, ej: 6=1+2+3
Elabore un algoritmo que permita buscar dentro de los numeros naturales, los primeros N numeros perfectos.
De antemano Gracias.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Algoritmo primeros N numeros perfectos

Publicado por Lorenza (1 intervención) el 01/05/2013 23:28:39
Claro, con gusto, aqui tienes el algoritmo en pseudo codigo:


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
Proceso PERFECTO
 
 
	//lectura de datos//
	Escribir "Digite la cantidad de numeros perfectos deseada"
	repetir
		Leer n
	hasta que n>0
 
	//inicializacion de variables//
 
	i<-1
	c<-0
	d<-0
	//proceso repetitivo y resultado//
 
	repetir
 
		d<-0
		i<-i+1
 
		Para x<-1 Hasta i-1 Hacer
 
			Si (i mod x)=0 Entonces
				d<-d+x
			FinSi
 
		FinPara
 
		Si d=i Entonces
			c<-c+1
 
			Escribir "número perfecto ",c, " es ",i
		FinSi
 
	hasta que c=n
FinProceso
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Algoritmo primeros N numeros perfectos

Publicado por moises A7x97_moy@hotmail.com (1 intervención) el 31/03/2016 20:08:29
Estoy comenzando a programar(aclaracion)...
¿que significa ' <- ' en la declaracion de variables?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar