Algoritmia - algoritmo

   
Vista:

algoritmo

Publicado por anderson (1 intervención) el 30/05/2014 19:45:57
Elaborar un algoritmo que pida el nombre de un alumno, sus 4 notas de sus 4 periodos y que de la nota definitiva que muestre un mensaje si aprueba si pierde o si queda en refuerzo o si pierde. Se sabe que para que un alumno apruebe debe obtener una nota de 4 hacia arriba para que quede en refuerzo su nota definitiva debe ser menor de 4 pero mayor o igual que 3 y para que pierda su nota definitiva debe ser menor que tres.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
1
Responder

algoritmo

Publicado por Marcos Andres (6 intervenciones) el 30/05/2014 22:26:36
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
Inicio
 
ingresar primer periodo:      leer primer
ingresar segundo preiodo : leer segundo
ingresar tercer preiodo :       leer tercero
ingresar cuarto preiodo :      leer cuarto
 
total = primer + segundo + tercero + cuarto
promedio = total/4
 
si  (total >= 4) entonces
{
imrimir "el alumno aprueba"
   si (total >= 3 y (total <= 4) entonces
        {
         imprimir: "queda para refuerzo"
sino
imprimir: el alumno pierda la nota en definitiva
fin si
}
finsi
}
finsi
 
Fin

saludos, espero haberte ayudado, o sino al menos una idea buena!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar