Algoritmia - Algoritmo para identificar números ambiciosos

   
Vista:

Algoritmo para identificar números ambiciosos

Publicado por Samuel (1 intervención) el 31/01/2016 02:14:28
ambiciosos

Necesito ayuda con esto, no logro repetir el proceso con números mayores a 95 que sean ambiciosos.

este es el codigo que estoy usando en Pseint.

Proceso Ambicioso

cont2<-1;
rest2<-0;
num<-0;
acum<-0;
acum2<-0;
cont<-1;


Escribir "Ingrese un numero mayor a 2 para saber si es ambicioso";
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
leer num;
 
	mientras cont<num/2 Hacer
		rest<-num MOD cont
		si rest=0 entonces
			acum<-acum+cont
		FinSi
		cont<-cont+1
	FinMientras
 
	Escribir acum;
 
	Repetir
 
	Mientras (cont2<acum) Hacer
 
		rest2<- acum MOD cont2
 
		si rest2=0 entonces
 
			acum2<-acum2+cont2
		FinSi
		cont2<-cont2+1
 
	FinMientras
 
	escribir acum2;
 
	si acum2<>25 entonces
 
		acum<-acum2
		acum2<-0
		cont2<-1
 
	FinSi
 
Hasta Que  cont2>=acum2
 
si acum=acum2  Entonces
 
	Escribir " el numero ingresado es ambicioso";
Sino
	escribir "el numero ingresado no es ambicioso";
FinSi
 
 
 
FinProceso
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder