Algoritmia - Llenar matriz sin repetir valores

   
Vista:

Llenar matriz sin repetir valores

Publicado por Daniel daniel.castro.ariza@hotmail.es (1 intervención) el 07/06/2016 01:58:56
Hola, estoy haciendo un algoritmo pero me falta una parte... El usuario debe ingresar valores para llenar una matriz 3x3 y que además éstos entén entre 0 y 9 pero no debe permitir que se repitan valores... Permitiendo repetir valores sería así:

1
2
3
4
5
6
7
8
9
10
11
12
13
Definir i, j, a como entero
Dimensión m[3,3]
 
Para i<-1 Hasta 3 Con Paso 1 Hacer
	Para j<-1 Hasta 3 Con Paso 1 Hacer
		Escribir "Introduce un numero para la posicion " i ","  j
		leer a
		Mientras a<0 o a>9 Hacer
			Escribir "Ha ingresado un numero fuera del rango, por favor digite nuevamente un numero entre 0 y 9."
			Leer a
		Fin Mientras
	Fin Para
Fin Para

Pero cómo hago para que no deje repetir valores????
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Llenar matriz sin repetir valores

Publicado por Juan R. (51 intervenciones) el 23/06/2016 11:02:23
Buenas Daniel

Es tan fácil como crear otro array (vector). Después, si estás en la posición [1,1] introduces el valor igual que en el array original. Después cada vez que introduces un nombre, recorres el array nuevo buscando si está el número, si está el número mandas un mensaje y vuelves a pedir el número, si no está lo introduces en ambos arrays.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar