Algoritmia - division de algoritmo

   
Vista:

division de algoritmo

Publicado por rafael landaeta (1 intervención) el 04/07/2008 19:15:57
Diseñe un algoritmo que lea dos numeros (A, B) y realice la division del primer numero leido (A) entre el segundo numero. DEbe tomar en cuenta lo siguiente:
º 0 / 0 = INDETERMINADO,
º Numero / 0 = Error !!
º 0 / Numero = 0
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:division de algoritmo

Publicado por jair esteban  (4 intervenciones) el 08/07/2008 14:52:28
inicio
leer n1,n2
div=n1/n2
si n1=0 and n2=0 entonces
div='indeterminado'
si n2=0 entonces
div='error'
si n1=0 entonces
div=0
fin si
fin si
fin si
imprimir div
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:division de algoritmo

Publicado por itvboy (4 intervenciones) el 23/09/2008 23:13:44
Hola, esta mal el algoritmo en la linea 3 linea, ya que no puedes dividir n1/n2 si n2 es un cero.
despues de leer los numeros, debes de comprobar que el divisor no sea cero, despues puedes proceder a hacer la division.

inicio
leer NUMERO1, NUMERO2

si NUMERO2 no es CERO entonces
imprimir NUMERO1 / NUMERO2
si no
si NUMERO1 es CERO entonces
imprimir "Division indeterminada"
si no
imprimir "Error de division por cero"

Checa, fueron solo 9 lineas, ahora esto en pascal seria

program DIVISION;
var NUMERO1, NUMERO2: integer;
begin
read(NUMERO1);
read(NUMERO2);

if NUMERO2 <> 0 then
writeln( NUMERO1 / NUMERO2 )
else
if NUMERO1 = 0 then writen( "Division indeterminada")
else
writeln( "Error de division por cero")
end.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar