Apache - problema con apache... deseperación

   
Vista:

problema con apache... deseperación

Publicado por seeburii (1 intervención) el 16/08/2012 16:09:33
Te cuento, he instalado AppServ, y al intentar abrir httpd.exe dentro de apache/bin me aparece este error:

"Solo se permite un uso de cada direccion de socket (protocolo/direccion de red/puerto): make_sock: could not bin to address 0.0.0.0:80 no listening sockets available, shutting down
Unable to open logs"

Este error me sale en la consola de MS2 y se cierra en medio segundo, he tenido que abrirlo muchas veces para leerlo. Quiero decir que ni me sale la pluma en la barra de tareas inferior derecha, ni nada, simplemente se cierra esa ventana y fin, aunque, en el administrador de tareas, en servicios, pone que "apache 2.2" y Mysql" están activos, en la ventana de servicios.

Está claro que esto es la causa de que al poner 127.0.0.1 o localhost en el explorador no pase nada, aunque sí tiene respuesta, en vez de quedarse cargando sale un mensaje casi instantáneo: "¡Vaya! Google Chrome no ha podido establecer conexión con la página 127.0.0.1."

Ya sé que es porque otro programa tiene ocupado el puerto 80, he probado a cambiar el puerto a 8080 (el cual he abierto en la página del router también) y nada. He leído que si obtienes respuesta es porque tienes corriendo un servicio IIS o algo así, pero las guías que he leído datan de incluso antes del 2008 y no sé como desactivar dicho servicio (he probado a desactivar todos y nada)

PD: Ahora con el TeamViewer abierto (porque he reiniciado, antes lo tenia cerrado) al introducir 127.0.01 me sale este mensaje:

This site is running TeamViewer.

Free Port 80 for other applications in advanced settings.


¿Qué puedo hacer para que me vaya Apache de una vez? :S

Uso windows 7 64 bits!

Gracias!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder