Apache - problema al configurar subversion en Apache

   
Vista:

problema al configurar subversion en Apache

Publicado por Francisco Javier (3 intervenciones) el 04/05/2015 13:13:10
Buenos días,
Me estoy montando un entorno de pruebas en local, para luego poder exportarlo al trabajo. Estoy utilizando un Windows 8.1

El caso es que instalo el XAMPP y al lanzar el apache, me salta este mensaje:

12:49:02 [Apache] Error: Apache shutdown unexpectedly.
12:49:02 [Apache] This may be due to a blocked port, missing dependencies,
12:49:02 [Apache] improper privileges, a crash, or a shutdown by another method.
12:49:02 [Apache] Press the Logs button to view error logs and check
12:49:02 [Apache] the Windows Event Viewer for more clues
12:49:02 [Apache] If you need more help, copy and post this
12:49:02 [Apache] entire log window on the forums


Lo soluciono entrando en Skype y desactivando los puertos 80 y 443 (tambien he llegado a editarlos ficheros httpd.conf y httpd-ssl.conf para modificar los puertos)

Una vez realizados esos cambios, reinicio Apache y funciona.
Despues de esto instalo Subversion. Sigo los pasos que he encontrado por internet, por ejemplo este: "http://heinsohn.wikidot.com/instaladores:subversion-apache-windows"
y al reiniciar Apache, me aparece el mismo mensaje de antes.

¿Me podéis ayudar con esto?

Muchas gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

problema al configurar subversion en Apache

Publicado por xve (236 intervenciones) el 04/05/2015 14:38:20
has probado con skype cerrado?

Lo que te esta diciendo, es que el puerto esta bloqueado...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

problema al configurar subversion en Apache

Publicado por Francisco Javier (3 intervenciones) el 04/05/2015 14:39:54
Si si, tengo Skype cerrado
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de xve

problema al configurar subversion en Apache

Publicado por xve (236 intervenciones) el 04/05/2015 15:55:12
Hola Francisco, el problema que te da, es que hay alguna otra aplicación que esta utilizando el puerto que tienes definido en el Apache... por defecto el 80.

Algunas veces, el problema es que tiene dos instancias del apache en el servidor... no se si este puede ser el problema.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

problema al configurar subversion en Apache

Publicado por Francisco Javier (3 intervenciones) el 04/05/2015 16:35:32
Buenas tardes.
Lo primero es daros las gracias por las respuestas.

Ya lo he solucionado. El tema es que la versión de Subversion no era compatible con Apache 2.4
He instalado una versión de Subversion compatible con Apache 2.4 y ya está corriendo ;)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de xve

problema al configurar subversion en Apache

Publicado por xve (236 intervenciones) el 04/05/2015 21:18:44
Gracias por comentarlo Francisco!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar