Apache - Extraño problema al subir imagenes

   
Vista:

Extraño problema al subir imagenes

Publicado por Robermix (1 intervención) el 25/01/2016 00:33:47
Hola,
el problema que tengo es que al subir fotos desde una aplicación android al servidor web apache las fotos son enviadas a un archivo php y este las guarda en un directorio, todo funciona correctamente cuando las fotos son subidas con wifi o 3G pero cuando se intentan subir usando una red 2G que es más lenta, a los 15 segundos de estar subiendo la conexión se corta y se produce el error ECONNRESET (Connection reset by peer) y la foto no sube al servidor, siempre sucede esto si la foto tarda en subir más de 15 segundos, pero si la foto es pequeña y se sube entera antes de 15 segundos entonces ya no se produce este error.

He probado a cambiar estas variables en el servidor:
max_execution_time = 120
max_input_time = 120

pero no ha dado resultado.

Me está sucediendo con un servidor de pago. He probado con un servidor gratis y lo curioso es que en ese sí funcionó.
¿Qué puede estar sucediendo?
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Extraño problema al subir imagenes

Publicado por xve (236 intervenciones) el 25/01/2016 07:40:02
Puede ser por problema del Apache o del PHP... deberías de revisar el log del apache, para saber con certeza quien emite dicho error.

Por defecto Apache, creo que lleva 300 segundos, pero puede ser que esta variado... revisa el archivo apache2.conf (según tu distribución) el valor de Timeout

Recuerda que cualquier cambio en la configuración del PHP o Apache, hay que reiniciar el Apache.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar