Apache - Problemas al actualizar Apache con Oracle Enterprise Linux 5.4

   
Vista:

Problemas al actualizar Apache con Oracle Enterprise Linux 5.4

Publicado por DELMO (1 intervención) el 16/06/2016 13:48:22
Buenos días!
Estoy teniendo problemas para actualizar mi apache 2.2.3 a 2.4.20

Tengo instalada una máquina virtual con Oracle Enterprise Linux 5.4, viene por defecto apache 2.2.3 (APR y APR-Util 1.2.7)

He probado yum upgrade httpd, yum update httpd y no me hace nada (error: no package matching...)

Me lo intento descargar e instalar manualmente. He leído que antes he de actualizar APR y APR-Util... así que me descargo y descomprimo apr-1.5.2 y apr-util-1.5.4,
hago el ./configure, make, make install y luego me descargo httpd-2.4.20 y hago lo mismo.

Al hacer el make del httpd me salen estos errores:

make[2]: *** [util_pcre.lo] Error 1
make[2]: se sale del directorio `/root/httpd-2.4.20/server'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/root/httpd-2.4.20/server'
make: *** [all-recursive] Error 1

Cuando vuelvo a comprobar la versión, me sale que tengo la 2.2.3... no hay manera de que se actualice...

¿Alguien sabe qué pasa, o si me falta hacer algo?
Muchas gracias!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder