Bases de Datos - Activar SQLITE en XAMPP 1.8.0

   
Vista:

Activar SQLITE en XAMPP 1.8.0

Publicado por Jhoan basura1973@gmail.com (4 intervenciones) el 19/09/2012 18:03:49
Amigos foreros muy buenas a todos. Resulta que quiero empezar a trabajar con php usando bases de datos de SQLITE, pero intento trabajar con ellas y al parecer no están habilitadas para el php de XAMPP ya que no me deja crearlas, ni hacer ningún tipo de operación o gestión con ellas.

La pregunta es ¿Cómo habilito SQLITE en XAMPP 1.8.0? según estuve leyendo en el manual de php hay que descomentar algunas lineas del php.ini y la que piden descomentar ya esta lista. Aquí les dejo las lineas que tienen que ver con SQLITE tal cual las tengo en mi php.ini para saber cual es el error o que lineas debo agregar y en que parte. Las características de XAMPP 1.8.0 son: Apache 2.4.2
MySQL 5.5.25a, PHP 5.4.4y phpMyAdmin 3.5.2

extension=php_pdo_sqlite.dll
;extension=php_pdo_sqlite_external.dll
extension=php_sqlite3.dll
; http://php.net/sqlite.assoc-case
;sqlite.assoc_case = 0
;sqlite3.extension_dir =

Les agradeceria muchísimo si me pudieran colaborar, de antemano muchas gracias y que Dios Los Bendiga.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Activar SQLITE en XAMPP 1.8.0

Publicado por gilbert gpalaciosconst@hotmail.com (1 intervención) el 09/04/2014 07:10:29
Jhoan. Yo tenía instalada la versión más reciente del XAMPP la 1.8.3-2 pero en esa versión no hay soporte para SQlite2 únicamente para SQlite3(al menos que haya alguna forma de activarlo desde el php.ini, o algo así) y la sintaxis SQLite3 cambia en gran manera y me resultó complicado cambiarlo y adaptarlo, mejor instálate la versión 1.7.4 del XAMPP y funcionará perfectamente, y no tendrás que adaptar código ni convertir nada.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Activar SQLITE en XAMPP 1.8.0

Publicado por Ever Rangel (1 intervención) el 15/07/2016 18:46:10
Si es así... solo tienes que descomentar la sig linea que esta dentro del archivo (php.ini), reiniciar el servidor apache y listo:

extension=php_sqlite3.dll

saludos y suerte!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar