Clipper/FiveWin - PROBLEMAS CON INDICE NTX

   
Vista:

PROBLEMAS CON INDICE NTX

Publicado por Martin (25 intervenciones) el 12/02/2008 23:16:26
Saludos a Todos

Tengo una base con la sgte estructura:
CODIGO C 9
SECCION C 2
DATA C 250
NUM N 2,0
Esta base tiene mas de 6'000,000 de registros, al crear con el DBU el indice:
CODIGO+SECCION+STR(NUM), y tratar de verlo desde ahi mismo o desde algun prg(atraves del depurador ) el resultado es campos en BLANCO, si quito el indice puedo ver el contenido.

Alguien podria indicarme como solucionar este problema

Saludos y Gracias

Martin
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:PROBLEMAS CON INDICE NTX

Publicado por Adalberto Baqueros (213 intervenciones) el 12/02/2008 23:43:34
Hola Martin.

Prueba con la instrucción siguiente:

INDEX ON ( Codigo + Seccion + STR( Num , 2 , 0 ) TO ArchNtx
GO TOP

Funciona!

Saludos, desde Santa Cruz de la Sierra - Bolivia.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:PROBLEMAS CON INDICE NTX

Publicado por Martin (25 intervenciones) el 13/02/2008 15:45:49
Saludos Adalberto

y gracias por responder, pero el problema continua , tienes idea de que puede estar pasando?

Espero sus opiniones

Saludos

Martin
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:PROBLEMAS CON INDICE NTX

Publicado por Marcelo (161 intervenciones) el 13/02/2008 23:50:26
tal vez tengas regitros en blanco y al indexar aparecen arriba...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:PROBLEMAS CON INDICE NTX

Publicado por Martin (25 intervenciones) el 14/02/2008 15:35:40
Hola Marcelo

No. no hay registros en blanco, debo aclarar que el campo DATA es de 256 y no 250 caracteres, el problema veulvo a mencionarles es que al abrir el indice desde el DBU por ejemplo los registros no muestran los valores de los campos estan en blanco y el campo NUMERO muestra el valor "0"

A la espera de su colaboracion

Saludos

Martin
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:PROBLEMAS CON INDICE NTX

Publicado por Adalberto Baqueros (213 intervenciones) el 15/02/2008 03:40:08
Martin,

Seguro que si comprimes el archivo DBF puedes enviarmelo y con gusto haré pruebas y las soluciones que encuentre te las comunico.

Saludos, desde Santa Cruz de la Sierra - Bolivia.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar