Crystal Report - Problema al conectar reporte

   
Vista:

Problema al conectar reporte

Publicado por Willians (7 intervenciones) el 10/01/2009 16:59:15
Buen dia,

La siguiente sintaxis la uso para cargar los reportes a mi sistema:

reportDocument1.FileName = My.Application.Info.DirectoryPath & "Reportes" & strNombreReporte & "" & ".rpt"
reportDocument1.Database.Tables.Item(0).LogOnInfo.ConnectionInfo.ServerName = strServer
reportDocument1.Database.Tables.Item(0).LogOnInfo.ConnectionInfo.DatabaseName = strDatabase
reportDocument1.Database.Tables.Item(0).LogOnInfo.ConnectionInfo.UserID = strUID
reportDocument1.Database.Tables.Item(0).LogOnInfo.ConnectionInfo.Password = strPWD
CrystalReportViewer1.ReportSource = reportDocument1
CrystalReportViewer1.LogOnInfo.Item(0).ConnectionInfo.ServerName = strServer
CrystalReportViewer1.LogOnInfo.Item(0).ConnectionInfo.DatabaseName = strDatabase
CrystalReportViewer1.LogOnInfo.Item(0).ConnectionInfo.UserID = strUID
CrystalReportViewer1.LogOnInfo.Item(0).ConnectionInfo.Password = strPWD

El problema es que cuando me cambio de servidor o base de datos, no se esta tomando en cuenta estos parametros sino que se conecta al servidor y base de datos con el que se guardo el reporte.

¿Cómo hago para que camnbie la conexión sin tener que ir al reporte y logear con el servidor y base de datos que deseo?

Gracias por su ayuda
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder