Crystal Report - Server has not yet been opened

   
Vista:

Server has not yet been opened

Publicado por Juanjo (1 intervención) el 05/03/2009 18:12:47
Hola a tod@s,

tengo el siguiente problema:
He entrado a trabajar en una empresa nueva y tienen una antigua aplicacion escrita en visual basic por un chico que se fue y no nos dejó ni el código fuente ni nada de documentación. Esta aplicación se conecta al servidor para leer unas bd access. La aplicacion puede insertar/modificar y borrar registros, pero utilizar Crystal Reports para generar informes y me sale el siguiente error cuando lo hace:

"Crystal Smart Viewer
Sever has not yet been opened"

He buscado información y hablan de librerias que hay que registrar. Pero he registrado ya unas cuantas y no me ha servido. Alguien sabe a que puede ser debido?

Muchas gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Server has not yet been opened

Publicado por luisa (1 intervención) el 13/03/2009 19:47:09
hola Juanjo
tengo el mismo problema que tu podiste resolver algo ??
me ayudas mil gracias
te dejo mi correo para que me contestes
mn.32@hotmail.com
saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Server has not yet been opened

Publicado por Juanjo (2 intervenciones) el 13/03/2009 19:53:25
Hola Luisa,

Si, el problema se refiere a que busca una ubicación de red, que no está disponible. En mi caso, era una carpeta z:/datos que tenia que estar mapeada.
Suerte y cualquier cosa, intentare ayudarte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Server has not yet been opened

Publicado por LUISA (2 intervenciones) el 13/03/2009 22:02:54
HOLA !
Gracias por contestar :)
si uso una unidad que esta mapeada.
solo que estoy teniendo problemas,quiero sacar mi reporte a web y
me sale ese horroroso erro :(

en el ser vidor de web mapee la unidad pero como que no la reconoce el reporte :(

saludos :)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Server has not yet been opened

Publicado por Juanjo (2 intervenciones) el 14/03/2009 12:53:41
Lo único que se me ocurre que pueda ser, es:
- Permisos de lectura en el servidor.
- Letra de unidad equivocada (en lugar de z: sea e:)
- O la ruta (que tengas z:/datos/ y sea z:/datos/datos2/

Prueba haber si es algo de esto, porque el mensaje "Server has not yet been opened" se refiere a que no encuentra la fuente de datos...

Espero que te sirva de ayuda.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Server has not yet been opened

Publicado por luisa (2 intervenciones) el 19/03/2009 23:37:52
hola !
pues sigue sin poder salirme el reporte :(
ya cheque los puntos que me mencionas y si es algo de los permisos
pero no se como ponerle los permisos a umi reporte de crystal
que cuando se conecte a la base de datos entre con ese usuario :(

gracias por tu ayuda :)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Server has not yet been opened

Publicado por oto (1 intervención) el 09/03/2010 05:15:40
no MI hermano , yo tambien tengo el mismo problema
y te cuento q no es por las librerias, si en el crystal report diseñador te habre el reporte y si lo corres , te va a pedir la contraseña y el usuario, lo mismo pasa cuando lo intentas abrir en el basic...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Server has not yet been opened

Publicado por Roberto (2 intervenciones) el 28/05/2010 03:30:00
Tenia el mismo problema y lo que hice fue abrir el archivo dsn y le agregue el siguiente renglon despues de UID=root:

PASSWORD=sa

Nota: sa es el password de mi servidor mysql

ahora solo llamo el reporte desde codigo vb6.0 de la misma manera que lo hago cuando utilizo, access o sql server... suerte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Server has not yet been opened

Publicado por NeoRod (1 intervención) el 06/08/2010 22:14:46
El problema esta cuando creas el usuario ODBC, no le has dado ni el usuario ni la contraseña del SQL server.
Revisa la conexion ODBC y prueba de nuevo a mi me funciono de maravilla.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Server has not yet been opened

Publicado por Gio (1 intervención) el 25/07/2016 18:24:19
Hola Que tal, buscando encontre este foro, tambien tenia este problema, y todo lo que probe fue:
1.- probar que la compu q se conecta al servidor estuviera en el mismo grupo de trabajo.
2.- mapear la unidad de red ya que de ahi jala las plantillas crystal. (eso lo hago conectando la unidad de red, haciendola logica y nombrandola tal como debe llamarse desde el programa que te da el error).
3.- creando en el origen de datos ODBC tanto el DNS de usuario como el DNS de sistema con los mismos nombres y credenciales para autenticarse a la base de datos.

Espero te ayude. tambien trabajo con bv6 y crystal.
espero pueda ayudarte.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar