Crystal Report - CrystalReportViewer, registra otra version

   
Vista:

CrystalReportViewer, registra otra version

Publicado por David (1 intervención) el 18/01/2011 13:32:44
Buenas tardes,

Llevo desde ayer a la tarde intentando hacer funcionar un reporte (que lo tenia funcionando) pero no lo consigo.
Cambie de version en las DLLS y al final, incluso he optado por crear un proyecto desde cero para evitar problemas.

En mi equipo funciona bien pero no en el servidor. Creo que el problema viene cuando arrastro el componente CrystalReportViewer (version 13.0.2000.0) a la pagina.
Arriba, me registra el assembly en version 10.x, ¿por qué?

Claro, luego a l ahora de ejecutar, me aparece vacio el reporte con el error 'bobj' no esta definido.

Decir, que cuando voy a escoger los items del ToolBox, los que estan seleccionados son los de la version 13, y no de la 10.

Me sorprendio tambien que al agregar las referencias a Crystal de la version 13, en el WebConfig, habia lineas de la version 10... que tampoco se de donde salen.

Cualquier ayuda será bien recibida, muchas gracias!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

CrystalReportViewer, registra otra version

Publicado por Mario Lagos (1 intervención) el 02/07/2011 05:39:00
Yo tambien tengo ese problema todo me funciona bien cuando lo ejecuto en el visual 2010 pero cuando lo subo al IIS 7 no me funciona me da el mismo error.

Detalles de error de página web

Agente de usuario: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)
Fecha: Wed, 29 Jun 2011 23:04:15 UTC


Mensaje: 'bobj' no está definido
Línea: 70
Carácter: 3
Código: 0
URI: http://localhost/misitio/Reportes.aspx
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar