Crystal Report - Subreporte no muestra datos filtrados en reporte

   
Vista:
Imágen de perfil de salomon

Subreporte no muestra datos filtrados en reporte

Publicado por salomon (3 intervenciones) el 29/01/2015 00:58:01
Hola Comunidad

Espero que alguien me pueda ayudar

Tengo un reporte para mostrar datos de factura, en ese reporte agregue un sub-Reporte para mostrar datos filtrados, cuando el programa ejecuta el reporte, los datos son mostrados sin filtrar del subreporte y cuando hago click en el subreporte los datos se muestran bien.

Alguien sabe como arreglar este problema que tengo?

Saludos

Aqui es la vista General delreporte, donde esta el cuadrado de contorno negro es donde esta ubicado el subreporte

FacturVista-General

Aqui es donde esta ubicado el subreporte

MICS

Aqui cuando se hace click al subreporte donde los datos estan correctos pero en el reporte matriz estan erroneos.


MICS1

si alguien puede ayudarme por favor.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Subreporte no muestra datos filtrados en reporte

Publicado por AVELINA (1 intervención) el 20/04/2015 18:09:35
Hola,

No sé si lo tendrás solucionado ya, pero el problema lo puedes tener con el campo del vínculo del report principal con el subreport, deberías vincularlos por el identificador de la factura o de la línea de la factura, no sé exactamente que datos saca el subreport, y así en el subreport solo saldrán los datos de la factura correspondiente.

Saludos,
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar