Crystal Report - Diversas Imagenes en el Reporte

   
Vista:

Diversas Imagenes en el Reporte

Publicado por jose (27 intervenciones) el 15/05/2008 02:15:30
Saludos

Tengo un reporte el cual tendra una o varias imagenes, y ese es el problema, no le puedo colocar la imagen predeterminadamente de forma fija porque esta imagen varia, puede ser una, otra u otra, e incluso podria ser más de una.

Nunca he hecho reportes con este perfil, por favor para quien maneje esto, como podria hacer para que un reporte (que ya tengo hecho) ahora involucre imagenes, ya que el problema aqui es el que las mismas pueden variar, que salgan en el reporte, sea una o varias imagenes.

Las imagenes ya estan scaneadas y guardadas en una carpeta, y se encuentran por nuemero, es decir: 1.jpg, 2.jpg, 3.jpg..... 84.jpg (son 84 imagenes en total)

Un cordial saludo.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Diversas Imagenes en el Reporte

Publicado por Sonia (2 intervenciones) el 16/05/2008 00:46:54
Tengo el mismo problema... Yo lo estoy solucionando de la siguiente manera:
Inserto una imagen vinculada a un archivo... y desde visual basic, reemplazo el archivo por la imagen que quiero mostrar en ese momento.
Para insertar una imagen vinculada, vas al menu Insert, seleccionas OLE Object, crear desde archivo... luego eliges la imagen y te aseguras que esté seleccionada la opción Vincular.
Pero tengo un problema, sólo puedo trabajar imagenes .bmp, no he podido trabajar con imagenes .jpg. Al tratar de insertar sale el siguiente error:
"No se puede crear el objeto. Compruebe que la aplicación está correctamente resgitrada en el sistema" y desde otra máquina no sale el error pero no se muestra la imagen...

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Diversas Imagenes en el Reporte

Publicado por Leobardo  (3 intervenciones) el 16/05/2008 18:24:03
Hola en este link hay algo que te pueda ayudar yo estoy tratando de hacer lo mismo que tu y este articulo me ayudo mucho el unico problema que tengo es que apartir de la seguna hoja empiezo a perder una imagen no se si puesas revisarlo haber si te ayuda.

Y espero que lo resuelvas es facil solo hay ese detalle que yo tengo pero no se si pasa siempre intentalo.

http://www.lawebdelprogramador.com/news/mostrar_new.php?id=22&texto=Crystal+Report&n1=385461&n2=0&n3=0&n4=0&n5=0&n6=0&n7=0&n8=0&n9=0&n0=0
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Diversas Imagenes en el Reporte

Publicado por erick geovanni alvarez samayoa (147 intervenciones) el 04/06/2008 16:10:18
bueno la solucion es hacerlo con el crystal report 11 DEVELOPER, la version 11 ya trae esta funcion, y puede mostrar las inmagenes a partir de una ruta, no hay necesidad de tener guardadas las inmagenes en la base de datos, y funciona muy bien, entonces se pueden cargar todas las inmagenes q quieran a partir de un campo de tu base que contenga la ruta

OJO: tienen que conseguir la version DEVELOPER, ya que la profesional no trae el Activex para ver los reportes ni las librerias para mostrar los reportes

si estan trabajando con crystal report antes de la version 9, la cosa es diferente porque en el 8.5 para abajo se usaba un ocx, ahora de la 9 en adelante es un dll y la forma de mostrar el reporte es un poquito diferente pero pueden buscar informacion sobre CRAXDRT

saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Diversas Imagenes en el Reporte

Publicado por adaris (4 intervenciones) el 17/05/2010 22:01:14
como lo hicistes?

porque yo hice lo siguiente:
En el campo que quiero vincular, entre a hipervinculo; un archivo y puse la direccion y el campo que va a variar:

"C:\" + CStr ({SPCUT_CONS_NOTA_ENT_Tx;1.NOTA_CTRL}, 0) +".pdf"

hasta aqui todo me funciona bien, cuando doy vista previa el link funciona correctamente me despliega cada campo con su imagen pdf correspondiente, todo desde el Crystal..

Pero cuando corro el reporte desde .net despliega el reporte pero al dar click sobre el hipervinculo no despliega nada, no abre el archivo pdf..

Que me faltara?
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar