Delphi - error usando zeos tzquery componente.

   
Vista:

error usando zeos tzquery componente.

Publicado por calabazaman (117 intervenciones) el 05/04/2011 18:00:11
Hola mundo que tal?

Tengo el siguiente codigo delphi 6 + zeos connection a Oracle database,

Lo vengo manejando con ado components pero deseo probarlo con zeos es un query muy sencillo, un select campos from tabla,

al inicio como tengo el select cargado en la propiedad sql me despliega los datos de la base de datos pero a la hora de querer crear el query en tiempo de ejecucion me genera el error.

Este me genera un error a la hora de realizar el open ora 000933 "comando no terminado bien." correo el query desde sqlplus y no me genrea error alguno.

Alguien podria ayudarme por favor.

conneccion por tzconection
uso componente qzquery = zadenc1

procedure carga1();
var a : string;
begin
zadenc1.Close;
v_str := ' select PROGRAM_NAME,PROGRAM_DESC,DRIVER_NAME,NUM_THREADS, ' +
' UPDATE_ALLOWED,PROCESS_FLAG,COMMIT_MAX_CTR ' +
' from restart_control ' ;

zadenc1.SQL.Add(v_str);
zadenc1.Active;
zadenc1.Open;


salufos

buenos dias

calabaxxa
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

error usando zeos tzquery componente.

Publicado por calabazaman (117 intervenciones) el 05/04/2011 18:27:10
Ya me respondo compañeros,

Era cuestion de investigar mas, pero ya lleva 1 dia con esto.

El problema estaba en la instruccion:
zadenc1.SQL.Add(v_str);

hay q reemplazar esta por :
zadenc1.SQL.Text := v_str;

saludos

calabaxxa
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar