Delphi - no funciona mi odbc despues de intslar mi aplicaci

   
Vista:

no funciona mi odbc despues de intslar mi aplicaci

Publicado por alberto ortiz (66 intervenciones) el 12/10/2007 01:42:06
Hola creo mi aplicacion , despues con el InstallShiel hize el programa de isntalacion, pero despues de instalarlo en una maquina distinta me marca un error que no encuentra el alias, lo unico que me queda es crear manual el odbc para que mi aplicacion funcione, lo que deseo es que cuando se instale se cree el alias independientemente de donde se instala la aplicacion, trabajo con delphi 5, hya alguna forma de hacer esto o se puede meduante codigo como en Visual Basic o asp
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:no funciona mi odbc despues de intslar mi aplic

Publicado por jose luis (159 intervenciones) el 12/10/2007 05:52:07
El instalshield debe de ser capaz de hacerlo automaticamente, es probable que no estes indicando bien la configuracion de la base de datos al crear el instalador, normalmente yo uso innosetup y con el puedo crear el alias para que al instalarlo funcione en la maquina cliente, no es necesario utilizar vb o asp, en dado caso puedes hacer que tu aplicacion utilice un alias dinamico para hacer eso puedos revisar el libro de la cara oculta de delphi 4
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar