Delphi - bug en report builder

   
Vista:

bug en report builder

Publicado por diego gutierrez (15 intervenciones) el 30/10/2007 01:26:42
Saludos tengo report builder enterprise 10.02, y hasta ahora eh trabajado bien, pero hoy me resulto algo bastante extraño, en mi reporte tengo 6 dbchart, los cuales obtienen sus datos en tiempo de ejecucion de 12 diferentes bdpipeline, y al darle ElReporte.print sin hacer nada mas, para ciertos datos de mi trabajo, si sale bien rel reporte

Pero luego cambio los datos contenidos en los datasource y al darle otra vez en impirmir al reporte me sale una hoja 100% en blanco, sin ninguna de las etiquetas que tenia y no me lanza ninguna excepcion ni nada por el estilo, y pues no logro identificar que es lo que esta pasando

A alguie le ha pasado algo similar que tenga alguna informacion acerca de porque pasa eso, me seria de gran ayuda

//este es el codigo que utilizo para mostrar el reporte, como veran, no creo que sea cosa de que mi codigo este incorrecto, 'listo' es una variable booleana
procedure TfrmTableroNominas.ImprimirClick(Sender: TObject);
begin
if listo then
begin
elReporte.Print;
end;
end;

Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
información
Otras secciones de LWP con contenido de Delphi
- Código fuente de Delphi
- Cursos de Delphi
- Temas de Delphi
- Chat de Delphi
información
Códigos de Delphi
- Notepad mejorado
- My Bomber Man
- Cargar un bitmap

RE:bug en report builder

Publicado por Carina (1 intervención) el 31/10/2007 14:04:48
Verifica si abris y cerras los bdpipeline y los DataSource....
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:bug en report builder

Publicado por Augus (15 intervenciones) el 31/10/2007 20:27:20
Encontre la solucion, todos los bdpipeline y datasource estaban corector, pero algo que no tenia en cuenta es que si un dbpipeline no contiene registros, el reporte sale totalmente en blanco

Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:bug en report builder

Publicado por Raul tarifa vega (1 intervención) el 12/03/2008 18:33:55
Alguien sabe como puedo sumar columanas en el report builder pero que me vaya calculando el total, segun una descripcion de otro campo cambie de estado, osea que tengo tema 1, cuatro veces y quiero que me sume la cantidad que tiene cada vez de tema1, y luego que me sume las 8 catidades que tenga tema2 , voy calculando subtotales, segun cambie el tema.
Si alguien me puede ayudar. Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar