Dev - C++ - ayuda para ejercicio en C

   
Vista:

ayuda para ejercicio en C

Publicado por jesus (1 intervención) el 05/12/2013 02:47:58
hola necesito ayuda, como resolver este ejercicio en C o C++



1) Escribir un programa en C que lea el nombre, edad, sexo y sueldo de N personas dados y determine:
• El salario promedio de los hombres
• El nombre del hombre con el sueldo mas alto
• El nombre del hombre con el sueldo mas bajo
• La edad promedio de las mujeres
• El nombre de las mujeres con salario comprendido entre 5.000 $. y 7.500 $. inclusive.



2) Conocido el consumo trimestral de electricidad de cada estado de Venezuela para el año 2012, se pide mostrar en listados separados el nombre de los estados que :
• Incrementaron en mas del 15% el consumo del segundo trimestre con respecto a su consumo en el primer trimestre.
• El consumo de electricidad en el tercer trimestre es mayor a la suma de los dos trimestres anteriores.
• El consumo en el cuarto trimestre supera el promedio general del país en el año.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de antonio junior

ayuda para ejercicio en C

Publicado por antonio junior (1 intervención) el 29/03/2014 05:42:20
Proceso Consumoestados
dimension estados[24],trimestre[24],trimestre2[24],trimestre3[24],trimestre4[24];
Escribir "ingrese el nombre para todos los estadosestado";

Para i<-1 Hasta 24 Con Paso 1 Hacer

Escribir "ingrese el nombre del estado ",i," :";
leer estados[i];
Escribir "ingrese el consumo del primer trimestre";
leer trimestre[i];
Escribir "ingrese el consumo del segundo trimestre";
leer trimestre2[i];
Escribir "ingrese el consumo del tercer trimestre";
leer trimestre3[i];
Escribir "ingrese el consumo del tercer trimestre";
leer trimestre4[i];

FinPara
Escribir "listado de estados que incrementaron en mas del 15% el consumo del segundo trimestre con respector a su consumo en el primer trimestre";
consumototal=0;
Para i<-1 Hasta 24 Con Paso 1 Hacer
Si (trimestre[i]*15/100)<(trimestre2[i]*15/100) Entonces
Escribir estados[i];
FinSi

FinPara
Escribir ("listado para los estados donde el tercer trimestre es mayor que la suma del primero y el segundo");
Para i<-1 Hasta 24 Con Paso 1 Hacer
Si (trimestre[i]+trimestre2[i]<trimestre3[i]) Entonces
escribir estados[i];
FinSi
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar