Eclipse - Abrí mi código fuente en eclipse y se llenó de caracteres extraños

   
Vista:

Abrí mi código fuente en eclipse y se llenó de caracteres extraños

Publicado por Leo (2 intervenciones) el 27/04/2015 17:44:09
Pues no sé qué más puedo explicar, el título lo dice todo. Abro mi código fuente en Eclipse y empiezo a ver cómo se empieza a cambiar el texto por códigos raros a medida que muevo el scroll. Esto lo hace ilegible para mí, pero el código se ejecuta con normalidad, por lo que he descartado que el archivo esté dañado.

Lo he abierto en distintos editores y dispositivos y el archivo se ve igual. ¿Qué puedo hacer?

Adjunto imagen.

codigo

Gracias de antemano.

Leo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de xve

Abrí mi código fuente en eclipse y se llenó de caracteres extraños

Publicado por xve (16 intervenciones) el 27/04/2015 22:21:03
parece como esta comprimido o codificado...

te pasa únicamente con este archivo? intenta abrirlo con un programa de comprimir y descomprimir, como puede ser 7zip...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Abrí mi código fuente en eclipse y se llenó de caracteres extraños

Publicado por Leo (2 intervenciones) el 28/04/2015 01:45:42
Pues solo me pasa con este archivo. Se me olvidó comentar que las últimas líneas del código sí son legibles... menos mal que tenía una copia de seguridad y, la verdad, es que no me llevó demasiado reescribir el código, pero ya tengo curiosidad de saber qué ha pasado.

He intentado abrirlo con winrar pero me sale lo mismo...

Saludos!

Leo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar