Eclipse - Eclipse no ejecuta las clases nuevas.

   
Vista:
Imágen de perfil de José Antonio

Eclipse no ejecuta las clases nuevas.

Publicado por José Antonio (1 intervención) el 12/01/2016 12:04:32
Buenas, tengo un problema con eclipse y es que desde hoy intento ejecutar cualquier clase que haya sido creada nueva y no la ejecuta, en su lugar ejecuta la última anteriormente ejecutada. Me explico:
Ejecuto una clase "X" creada un día anterior, se ejecuta e imprime por consola sin ningún problema.
Ejecuto una clase "Y" nueva y no se ejecuta, en su lugar, se ejecuta e imprime la anterior.
No consigo encontrar la solución al problema y ando un poco desesperado.
Gracias de antemano.
Un saludo.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Eclipse no ejecuta las clases nuevas.

Publicado por arck (1 intervención) el 12/01/2016 16:23:28
Nunca me ha pasado eso y es muy raro, ¿partimos de la base que no puede ser error de programación? a lo mejor esperas que se ejecute por llamada de otra clase y esa clase no la llama.


Se que es una tontería pero,¿ tienes todos las consolas de salida borrados?
A lo mejor te esta mostrando los de la clase de ayer y los nuevos lo tienes por detrás.
Ve a la consola y en la Display Selected Console comprueba cuantas ejecuciones tienes tienes y elimínalas dando al botón de las dos X.
Y prueba a ejecutar de nuevo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar