Excel - Comparacion de valores

   
Vista:

Comparacion de valores

Publicado por Miguel Angel (3 intervenciones) el 17/10/2008 09:38:28
Tengo una pequeña duda.

Tengo un libro donde tengo tres columnas. una llamada "desde", otra "hasta" y otra "valor"
Lo que quiero es poner un valor en otra celda de otro libro y compare si el valor introducido está entre el valor desde hasta. Os pongo el ejemplo real

DESDE HASTA VALOR

19.943,04 999.999,00 654,78
13.817,33 19.943,03 523,83
10.054,08 13.817,32 419,07
7.598,19 10.054,07 335,26
5.436,60 7.598,18 301,74
3.897,22 5.436,59 271,57
3.230,83 3.897,21 244,41
2.420,26 3.230,82 219,97
0,00 2.420,25 197,98

Si Introduzco 2000 y me tiene que devolver el valor 197.98.
Por otro lado si introdusco 50.000 me tiene que devolver el valor 654.78.

Espero vuestra ayuda. Un saludo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Comparacion de valores

Publicado por jcs (494 intervenciones) el 17/10/2008 13:03:33
Muy buenas,

lo que planteas tendría una solución muy sencilla si lo valores que tienes estuvieran ordenados de forma ascendente, esto es:

0,00 2.420,25 197,98
2.420,26 3.230,82 219,97
...
19.943,04 999.999,00 654,78

bastaría con utilizar la función BUSCARV de esta forma

=BUSCARV(E1;A1:C9;3;VERDADERO)

así, si no te causa ningún trastorno, ordena los datos.

Si no puedes ordenar los datos de esa forma, y nadie te da otra solución mejor, dímelo y te preparo una macro.

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Comparacion de valores

Publicado por Miguel Angel Corrales (3 intervenciones) el 17/10/2008 23:41:18
Muchas gracias, me vale la formula que me das. Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar