Excel - conflicto contar.si

   
Vista:

conflicto contar.si

Publicado por roxxane (2 intervenciones) el 22/10/2008 02:06:31
HOLA

Tengo una tabla con los campos:

a b
1 hora descripcion
2 10:20 Resuelto
3 12:50 Pendiente
4 15:10 Pendiente
5 10:10 Resuelto
6 13:12 Resuelto

En otra hoja necesito que me aparezca lo siguiente

horario cantidad pendientes resueltos
1 10-11 2 0 2
2 11-12 0 0 0
3 12-13 1 1 0
4 13-14 1 0 1

es decir por hora cuantos registros tengo y de acuerdo a la hora cuantos pendientes y cuantos resueltos, esto automaticamente en una tabla
ya he solucionado el del horario con la formula :

contar.si(hoja1!a2:a200,">10:00")-contar.si(hoja1!a2:a200,">=11:00")

intento mpodificar contar si para que me arroje lo demas pero aun no aparece el resultado deseado. alguien sabe alguna manera de lograrlo, o que me falla???? xfavor

ESTE ES EL QUE USE
CONTAR.SI(Hoja1!B2:B30000(SI(Hoja1!D3:D19430,">=09:30:01"),SI(Hoja1!D3:D19430,">=09:59:59")),"=venta ok")
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:conflicto contar.si

Publicado por jcs (494 intervenciones) el 22/10/2008 11:00:30
Muy buenas,

yo te haría una sugerencia, y es que utilizases una tabla dinámica. Sin embargo, en vez de utilizar los datos de la columna A, utiliza los de la columna C en la que previamente habrías puesto la fórmula =HORA(A2).

No obstante, si quieres seguir utilizando tu planteamiento, prueba con lo siguiente:

=SUMAPRODUCTO((HORA(Hoja1!A$2:A$200)>=A2)*1;(HORA(Hoja1!A$2:A$200)<A2+1)*1;((B$2:B$200)="Pendiente")*1)

Seguramente tendrás que cambiar todos los ; (punto y coma) por ,

Espero que te sirva.

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar