Excel - Dar valores a letras

   
Vista:

Dar valores a letras

Publicado por Raquel1981 (2 intervenciones) el 04/02/2010 17:17:03
Soy una inexperta en Excel. Quisiera hacer lo siguiente: Dar valores a letras. Ejemplo:
En una celda poner A, en otra B, en otra C, donde A=5, B=8, C=10, y luego sumar esos valores en una celda nueva, ¿Se puede hacer? ¿Como? ¿que pasos debo dar?
Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Dar valores a letras

Publicado por eduardo (3 intervenciones) el 04/02/2010 19:55:44
hola me llamo eduardo si se puede http://www.aulafacil.com/Excel/Lecc-23.htm
es una pgina para que teguies solo deebs practicar, practicar, y seras un experto jajaj suerte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Dar valores a letras

Publicado por Raquel (2 intervenciones) el 05/02/2010 22:04:00
Quizás no me he expresadao correctamente. En una hoja excel quisiera poner en diversas celdas los turnos de trabajo expresados con letras, por ejemplo: M de Mañana, T, de tarde y N de noche, y dar valor numerico a cada letra, es decir a la mañana "M", 7 horas, a la tarde "T" 8 horas y a la noche "N" 9 horas y luego en celda nueva sumar todas las horas del mes,
Ejemplo; M M T N T M = 46 HORAS

Gracias y un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Dar valores a letras

Publicado por frany (62 intervenciones) el 06/02/2010 15:19:53
No tengo idea de como hacerlo sin código.
Así que prueba con este codigo en VBA.
Lo metes en un modulo de tu libro y a continuacion usa la formula creada en la celda que quieres que aparezca la suma total de la forma =turno(A1:F1) o bueno el rango que selecciones claro.
Un saludo.

Function turno(rango As Range)

For Each letra In rango
dato = letra

Select Case dato
Case Is = "M"
valor = 7
Case Is = "T"
valor = 8
Case Is = "N"
valor = 9
End Select

suma = suma + valor

Next letra

turno = suma

End Function
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Dar valores a letras

Publicado por javiergomiz (1 intervención) el 29/09/2016 22:46:59
los valores que están entre comillas son los turnos, puedes crear tantos turnos diferentes como quieras y luego verás un asterisco con un valor a continuación, esas son las horas que dependiendo de tu turno has de cambiar. Suerte!

=SUMA(B4:AF4)+CONTAR.SI(B4:AF4,"T")*7+CONTAR.SI(B4:AF4,"M")*7+CONTAR.SI(B4:AF4,"D")*14+CONTAR.SI(B4:AF4,"P")*7+CONTAR.SI(B4:AF4,"Z")*7+CONTAR.SI(B4:AF4,"R")*12+CONTAR.SI(B4:AF4,"A")*10
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Dar valores a letras

Publicado por Raziel (243 intervenciones) el 06/02/2010 19:51:58
Probe esta formula en mi maquina (Excel 2007, configuracion regional de Mexico) y funciono...

Suponiendo que los valores que quieres sumar estan en A1 y B1...

=BUSCAR(A1,{"A";"B";"C"\5;8;10})+BUSCAR(B1,{"A";"B";"C"\5;8;10})

Esta formula podria o podria no funcionar si lo copias directamente tal como la ejemplifico, si no funciona intenta cambiar \ por una coma y deberia quedar.

Aqui lo que hicimos es crear constantes matriciales donde el punto y coma represente la division de columnas y \ representa el termino de la fila, en otras palabras una simple y llana tabla "virtual".

Cuentanos como te fue...

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

RE:Dar valores a letras

Publicado por Joan (8 intervenciones) el 09/02/2010 18:14:44
Hola Raquel

Yo en un horario he hecho lo siguiente en una cacilla pongo el valor de cada letra luego pongo las letras en casillas que corresponde al dia del mes y en otra la funcion contar si. porlo que mecuenta las letras luego las multiplico por la casilla que tiene el valor.
No se si me expreso bien, aber si te sirve
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Dar valores a letras

Publicado por MArcela Vidal (1 intervención) el 29/10/2013 21:53:29
pon el la celda A2 a
en la celda A3 b
En la Celda A4 c


y en la celda A5 copia y pega esta formula y listo!!


=SUMA(SI(A2="A";10;SI(A2="b";15;SI(A2="c";20;"no")));SI(A3="A";10;SI(A3="b";15;SI(A3="c";20;"no")));(SI(A4="A";10;SI(A4="b";15;SI(A4="c";20;"no")))))
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:Dar valores a letras

Publicado por Ilmar Ramon ilmarr@hotmail.com (1 intervención) el 07/04/2015 18:48:27
Esta formula es la que me funciono
Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Dar valores a letras

Publicado por yonny torrado (1 intervención) el 03/01/2015 15:09:47
hay una manera muy simple

=si(A1="A";5)+SI(B1="B";8)+......+SI(XY"LETRA";VALOR)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar