Excel - comparar dos tablas

   
Vista:

comparar dos tablas

Publicado por marcelo (2 intervenciones) el 18/11/2010 20:55:37
Hola a todos, tengo un problemilla que espero poder solucionar, les explico, Tengo 2 tablas con los mismos datos una supuestamente tiene los mismos datos y otra tiene lo mismo pero algunos registros mas. Ahora la cuestion es la siguiente quiero comprar las dos tablas y saber que datos no hay en una tabla y/o que datos no estan en la otra tabla.

Explico mejor:
En la HOJA1 esta una tabla con varios registros los datos por ejemplo son:

CODIGO ITEM DESCRIPCION CANTIDAD
A1 0001 HOJAS BOND 500
A2 0004 SOBRES MANILA 100
B4 0007 PAPEL DE COLORES 50
H8 0009 PAPEL HIGIENICO 20

En la HOJA2 esta la siguiente tabla:

CODIGO ITEM DESCRIPCION CANTIDAD
A1 0001 HOJAS BOND 500
B4 0007 PAPEL DE COLORES 50
H8 0009 PAPEL HIGIENICO 20
A2 0006 CUADERNO 80
J9 00010 LAPIZ 100

En la hoja 3 tendria que dar los siguientes resultados:

DATOS QUE NO ESTAN EN LA HOJA1:

CODIGO ITEM DESCRIPCION CANTIDAD
A2 0006 CUADERNO 80
J9 00010 LAPIZ 100

DATOS QUE NO ESTAN EN LA HOJA2:

CODIGO ITEM DESCRIPCION CANTIDAD
A2 0004 SOBRES MANILA 100

Estos datos anteriores son solo ejemplos para ilustrar lo que quiero hacer, espero me entiendan y me puedan ayudar.
Gracias de antemano
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:comparar dos tablas

Publicado por pitu (40 intervenciones) el 19/11/2010 04:00:44
debes usar un buscarv, esto es =buscarv(dato deseado; matriz en la que buscas; posicion de la columna en la matriz anterior del dato que quieres recibir; 0)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:comparar dos tablas

Publicado por Luis Fernando Giraldo (805 intervenciones) el 19/11/2010 05:26:43
Complementando lo que dice PITU puedes usar algo como:

Sobre cada registro de la hoja1 debes tener

=BUSCARV(B1;Hoja2!B:B;1;0)

Sobre cada registro de la hoja2 debes tener

=BUSCARV(B1;Hoja1!B:B;1;0)

Y para cada registro que tengas #N/A como resultado quiere decir que ese elemento no existe en la otra hoja sobre la columna B
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

RE:comparar dos tablas

Publicado por marcelo (2 intervenciones) el 19/11/2010 14:26:38
Gracias ya lo solucione de nuevo gracias por el dato Pitu y Luis Fernando
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar