Excel - Sumar-Largo

   
Vista:

Sumar-Largo

Publicado por Pascual Pérez (1 intervención) el 19/11/2010 19:11:43
Buenas tardes amigos, tengo un problema y quisiera pedir vuestra cooperación,
Problema:
En A1 tengo los datos siguientes 20,30,40,N5,Ci1
El resultado tiene que ser 5, puesto que considero como 1 cada grupo de números o letra y número que hay entre las comas(,)
Si A1 es 20,30,40,N5,Ci1 y B1 es 45,C1 el resultado de estas dos columnas tiene que ser 7.
Si la celda esta vacia el resultado ha de ser 0.
Gracias por vuestro tiempo.
Un saludo.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

RE:Sumar-Largo

Publicado por Luis Fernando Giraldo (805 intervenciones) el 20/11/2010 02:05:59
Puedes usar algo como lo siguiente:

=SI(A1="";0;LARGO(A1)-LARGO(SUSTITUIR(A1;",";""))+1)

con ello evaluas primero si está en blanco para dar el resultado de CERO y luego calcula cuantas comas tiene el texto y le suma UNO.

Cordial saludo desde Pereira Colombia
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar