Excel - Buscar con dos condiciones o más

   
Vista:

Buscar con dos condiciones o más

Publicado por Cglez (2 intervenciones) el 20/07/2011 21:19:00
Hola, Amigos.

Necesito una formula de excel con la función buscarv (u otro si es la más apropiada) que ayude a visualizar la información añadiendo más de una condición: Se necesita que las dos columnas primeras sean condición y la tercera sea el resultado: ejemplo, A001 (columan A) y 3 (Columana B) = 17.00. Es una especie de dos búsquedas en una: primero que busque la primera referencia en la columna A y la segunda en la columna B y de ahí arroje el resultado que está contenido en la columna C.

A B C
------ ------ --------
A001 1 20.00
A001 1A 30.00
A001 2 88.00
A001 3 17.00
A001 4 33.00


Agradezco a quien me pueda ayudar.

Saludos!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Buscar con dos condiciones o más

Publicado por Armando (126 intervenciones) el 20/07/2011 22:06:00
Una forma con valores a buscar en F1:F2:
=INDICE(C1:C5,COINCIDIR(F1&F2,INDICE(A1:A5&B1:B5,0),1))
Tal vez debas cambiar las comas por punto y coma.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Gonzalo

Buscar con dos condiciones o más

Publicado por Gonzalo guliquin03@yahoo.com.ar (70 intervenciones) el 21/07/2011 17:23:27
Hola Cglez:
Te comento que debes tener cuidado con la fórmula escrita por Armando dado que si el valor no existe en tu matriz toma el último valor y si p.e. pusieses 50 y no exista, pero si existe el 5, te trae el valor de la coincidencia del 5.
Saludos,

Gonzalo

Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Buscar con dos condiciones o más

Publicado por Cglez (2 intervenciones) el 25/07/2011 21:03:47
Amigos, un millón de gracias por su valiosa y úitil ayuda.

Saludos!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Buscar con dos condiciones o más

Publicado por Hector (1 intervención) el 12/09/2013 00:39:28
Muchísimas gracias Armando, tenia días buscando algo para realizar una búsqueda con 2 criterios, y la formula que colocaste me dio la pista adecuada para hacerla mil gracias.!!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Buscar con dos condiciones o más

Publicado por Gibran (1 intervención) el 09/10/2014 23:01:04
Perdonen la ignorancia pero como quedaría la formula al final, aún no le doy!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar