Excel - sumar dentro de una rango de horas

   
Vista:

sumar dentro de una rango de horas

Publicado por christian christian.templario@gmail.com (2 intervenciones) el 08/05/2012 09:30:07
tengo una planilla en donde en la columna D tengo las horas de ventas por ejemplo 09:30 PM, 09:44 PM y 09:52 PM, 10:05 PM, 10:16 PM y 10:46 PM; en otra columna I tengo el monto de la venta en esos determinados tiempos, deseo sumar las casillas que estén en el rango de 1 hora desde las 09:00 PM hasta las 09:59 PM; y en otra sumar desde las 10;00 PM hasta las 10:59 PM
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

sumar dentro de una rango de horas

Publicado por jcs (494 intervenciones) el 09/05/2012 09:04:16
Muy buenas.

La mejor opción para eso es crear una tabla dinámica en la que agrupes el campo horas, precisamente por eso, por horas.

Si quieres el resultado en una celda concreta, te podría valer una fórmula como la siguiente:
=SUMAR.SI(A2:A1000;"<11:00";B2:B1000)-SUMAR.SI(A2:A1000;"<10:00";B2:B1000)

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

sumar dentro de una rango de horas

Publicado por christian christian.templario@gmail.com (2 intervenciones) el 14/05/2012 03:30:27
Juanjo muchas gracias me sirvio mucho esta formula... pero se produce un conflicto cuando pongo:

=SUMAR.SI(D:D;"<12:00 AM ";I:I)-SUMAR.SI(D:D;">11:00 PM";I:I) me multiplica el resultado por -1 lo soluciono multiplicando todo por menos 1

=(SUMAR.SI(D:D;"<12:00 AM ";I:I)-SUMAR.SI(D:D;">11:00 PM";I:I)) pero por que sucede esto???
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

sumar dentro de una rango de horas

Publicado por Armando Montes (240 intervenciones) el 10/05/2012 09:09:02
Otra formula:
=SUMAPRODUCTO((HORA(A$2:A$22)=HORA(D2))*B$2:B$22)
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar