Excel - Calcular dias

   
Vista:

Calcular dias

Publicado por Mitchell (4 intervenciones) el 10/05/2012 16:29:08
Buen dia foreroso, tengo este código y no me esta funcionando bien pueden ayudarme por favor

=SUMAPRODUCTO((DIA($A2:$A11)=C2)*($B2:$B11>NSHORA(12,0,0))*($B2:$B11<NSHORA(1,0,0)))

Ubico de esta formar los registros
En la columna A tengo
01/01/2012
En la columna B
12:00 a.m.
En al columna C, obtengo el dia con la formula =dia(a2)
1
Lo que necesito es por ejemplo dentro un rango de hora de 12:00 a 01:00 cuantos días numero 1 se encuentran registrados.


Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Calcular dias

Publicado por jcs (494 intervenciones) el 11/05/2012 22:54:31
Muy buenas.

Esa fórmula te dará siempre cero. La hora nunca puede ser superior a las 12 e inferior a la 1. Si quieres poner la una de la tarde, en la función NSHORA tienes que poner las 13.

Supongo que serás lo que quieres.

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar