Excel - Buscar en una matriz con condiciones

   
Vista:

Buscar en una matriz con condiciones

Publicado por jazo (5 intervenciones) el 07/05/2013 02:36:42
Amigos. Planteo lo siguiente. Necesito buscar el valor de la columna D de la hoja "CEU" en una matriz de otra hoja "Maestra". Si el valor esta dentro de un rango A11: B18 que me copie la cadena de la columna C. La funcion se debe copiar en la columna M2 (Sector) de la hoja CEU. E l archivo que subi se llama Rutas(Clientes).

Hoja Maestra
A---------------B--------------C
1200-------- 1329-------- 5° Y 6° Region
1200-A01-- 1329-A03-- 5° Y 6° Region
1200-FOC- 1329-FOC- 5° Y 6° Region
1457-001-- 1457-006-- 5° Y 6° Region
1351-------- 1456-------- RM
1351-FOC- 1456-FOC- RM
1351-A01-- 1454-a03-- RM
1457-01---- 1457-39---- RM

Hoja CEU
--D-----------------------M
1393
1221
1444
1444-A03
1373
1408
1386-FOC
1389
1226-a02
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Buscar en una matriz con condiciones

Publicado por Jazo (5 intervenciones) el 08/05/2013 19:39:04
Muchachos despues de varias pruebas la solucion ya esta lista:



=SI(D2="","",SI(Y(VALOR(EXTRAE(D2,1,4))>1199,VALOR(EXTRAE(D2,1,4))<1300),"5ª Region",SI(Y(VALOR(EXTRAE(D2,1,4))>1299,VALOR(EXTRAE(D2,1,4))<1330),"6ª Region",SI(Y(VALOR(EXTRAE(D2,1,4))>1350,VALOR(EXTRAE(D2,1,4))<1457),"RM",SI(Y(VALOR(EXTRAE(D2,1,4))>1100,VALOR(EXTRAE(D2,1,4))<1135),"Norte",SI(O(D2="1457-005",D2="1457-006"),"6° Region",SI(O(D2="1457-001",D2="1457-002"),"5ª Region",SI(O(D2="1457-003",D2="1457-004"),"6° Region",SI(D2="1457-10","5° Region","RM")))))))))
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar