Excel - AYUDA SOBRE SI(X="";0)

   
Vista:

AYUDA SOBRE SI(X="";0)

Publicado por NELHER2009 (2 intervenciones) el 02/11/2013 02:16:31
PIDO AYUDA PARA RESOLVER ESTE PROBLEMITA.

B C D
1
2
3 50 __ 55

FORMULA EN D3,
DATO DE ENTRADA EN EN C3
VARIABLE FIJA B3, NO SE TOCA COMO REFERENCIA.
FORMULA DE EN D3: =SI(SI(C3="";C3<0;0);0;SI(D3>C3;D3;SI(D3>0;D3;)))

EL PROBLEMA, ES QUE EN D3 DEBE DARME 0 Y NO 55, CUANDO NO ES CERO SINO ESPACIO VACIO.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

AYUDA SOBRE SI(X="";0)

Publicado por Martha (270 intervenciones) el 04/11/2013 19:13:25
Tienes un error de concepto.

La función SI es como sigue:

SI ("Prueba lógica"; "valor si verdadero"; "valor si falso")

En cuanto introduces punto y coma ( ; ) Excel entiende que estás terminando la prueba lógica y empiezas con el valor si verdadero.

Por otro lado, si no pones nada en valor si verdadero o valor si falso, la función te devolverá VERDADERO, FALSO o cualquier otra cosa.

Por tanto, "prueba lógica" puede ser lo que tu quieras o necesites. Si necesitas que la prueba lógica cumpla dos condiciones a la vez, comienza por Y, y si necesitas que prueba lógica culpla alguna condicion entre varias, comienzapor O. Pero siempre debe ser algo que de como resultado Verdadero o Falso.

Por ejemplo SI ( O (C3=""; C3<0)... Es decir, si C3 esta vacio o es un número negativo...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar