Excel - Como funciona Contar elementos distintos en un rango?

   
Vista:

Como funciona Contar elementos distintos en un rango?

Publicado por pablo (1 intervención) el 17/11/2013 19:06:38
Hola!
Necesitaba contar los valores distintos que aparecen en una columna de excel y buscando por ahí encontré la fórmula:

=SUMAPRODUCTO(1/CONTAR.SI(A1:A10;A1:A10))

la cual funciona!!.. pero mi duda es ¿como es que funciona?

Agradezco si alguno responde, para aprender un poco más.

saludos!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Como funciona Contar elementos distintos en un rango?

Publicado por jcs (494 intervenciones) el 17/11/2013 20:09:04
Muy buenas.

Efectivamente funciona, y desde luego me ha parecido una solución muy ingeniosa para lo que necesitas. SUMAPRODUCTO sirve para eso, para sumar multiplicaciones. En este caso no hay multiplicaciones y simplemente se limita a realizar 10 sumas. Para explicarlo mejor voy a utilizar un ejemplo. Imagina que tienes 4 datos iguales, luego otros tres, otros dos y uno. Algo así como
10
10
10
10
20
20
20
30
30
40

Aquí tienes que el resultado que necesitas es 4. Pues bien, lo que se hace es sumar el resultado de dividir 1 entre el número de veces que aparece, o sea, que los 10 sumandos serían los siguientes:
1/4
1/4
1/4
1/4
1/3
1/3
1/3
1/2
1/2
1/1

El número de veces que aparece se calcula con CONTAR.SI(A1:A10;A1:A10). En general, si un número aparece x veces, se sumará x veces, 1 partido por x, que siempre será 1.

Con el mismo sentido que la fórmula que has puesto, operaría la fórmula matricial siguiente:
=SUMA(1/CONTAR.SI(A1:A10;A1:A10))
Que hay que validar con CONTROL+MAYÚSC+INTRO

Espero haberme explicado.

Un saludo. Juanjo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Como funciona Contar elementos distintos en un rango?

Publicado por Cacho (44 intervenciones) el 17/11/2013 20:29:41
Hola! Pablo.
- Selecciona la celda que contiene la fórmula en cuestión;

- En la barra de fórmulas seleccionarás (con tu ratón) la siguiente parte:
CONTAR.SI(A1:A10;A1:A10)

tras lo cual, presionarás la tecla F9.

- ¿Eres capaz de interpretar el resultado obtenido?...
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar