Excel - Consulta sobre fórmulas condicionales EXCEL 2007

   
Vista:

Consulta sobre fórmulas condicionales EXCEL 2007

Publicado por Escobator (3 intervenciones) el 19/01/2014 13:26:16
Hola a todos,

Agradecería que alguien de vosotros pudiera ayudarme para escribir correctamente una fórmula condicional en Excel 2007. El problema que planteo es el siguiente: en una celda (la C33), quiero que salga un determinado valor en función de que, otro valor (en la celda C30) se encuentre en un determinado rango de valores de facturación (€).
Los rangos de facturación són: (inferior a 10.000 euros); (de 10001 a 12.000 euros) y (superior a 12.000 euros). Así, si el importe de facturación de la celda C30 se encuentra en el primer rango (inferior a 10.000), la celda C33 debería poner automáticamente 600 €; si el valor de facturación se encuentra dentro del segundo rango (de 10.001 a 12.000), la celda C33 debería cambiar a 700 € y, si el valor de facturación es superior a 12.000, la celda debería poner 800 €.
Muchísimas gracias y un saludo
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

Consulta sobre fórmulas condicionales EXCEL 2007

Publicado por Martha (270 intervenciones) el 19/01/2014 23:08:46
Solo tienes que anidar dos condiciones SI:

1
=SI(C33>12000;800;si(C33>10000;700;600))

Esta es la mecánica. Y se interpreta de la siguiente forma:
Si el valor de C33 es superior a 12.000 pones 800, en caso contrario, si es superior a 10.000 pones 700 y si no pones 600.
Verás que para 10.000 pone 600, aunque ya pone 700 en 10.000,01. Si no te gusta pon >= 10.001.
También deberías anidar una condición para previa para cuando C33 está todavía vacía.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Consulta sobre fórmulas condicionales EXCEL 2007

Publicado por Escobator (3 intervenciones) el 20/01/2014 11:49:34
Muchas gracias Martha, la verdad es que ha funcionado. Por último, el supuesto que os planteo está relacionado con el anterior pero se complica un poco más. Lo he intentado pero no me sale (no sé si son los paréntesis, la Y,..). Cómo se escribiría una fórmula condicional con las siguientes premisas:

- Si D40 es superior a 16.000, entonces poner 1000
- Si D40 es inferior o igual a 16.000 pero superior a 14.000, entonces poner 900
- Si D40 es igual o inferior a 14.000 pero superior a 12.000, entonces poner 800
- Si D40 es igual o inferior a 12.000 pero superior a 10.000, entonces poner 700
- Si D40 es igual o inferior a 10.000, poner 600

Agradezco de antemano vuestras respuestas
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Antoni Masana

Consulta sobre fórmulas condicionales EXCEL 2007

Publicado por Antoni Masana (265 intervenciones) el 22/01/2014 11:21:15
Esta es la formula de Martha ampliada a los 5 supuestos

1
=SI(D40>16000 ; 1000 ; SI(D40>14000 ; 900 ; SI(D40>12000 ; 800 ; SI(D40>1000; 700 ; 600 ))))

Visto en formato de Programación

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
SI D40>16000 ;
       1000
    ELSE
       SI D40>14000 ;
          900
       ELSE
          SI D40>12000 ;
             800
          ELSE
             SI D40>1000 ;
                700
             ELSE
                600
             ENDIF
          ENDIF
       END IF
    END IF

Si ves clara esta sintaxis cambia:

- Los SI por SI(
- Los ELSE por ;
- Los END IF por )

Y todo en una sola línea y ya tienes la función, pero OJO hay un limite en encadenado de funciones, en caso de superar el limite o hacerse muy compleja seria mas conveniente llamar a una función personal.

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

Consulta sobre fórmulas condicionales EXCEL 2007

Publicado por GUILLEM (3 intervenciones) el 22/01/2014 11:53:00
Muchas gracias Antoni, me ha servido de gran ayuda. Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar