Excel - Formula para diferenciar positivo de negativo

   
Vista:

Formula para diferenciar positivo de negativo

Publicado por Mogor (2 intervenciones) el 02/07/2014 22:25:53
Hola amigos, no consigo encontrar una formula para lo siguiente, tengo dos columnas que tengo que restar entre ellas, y el resultado dependiendo si este es positivo o negativo deberá de ir a otras columnas diferentes es decir, el positivo irá a una columna y el negativo a otra. Muchas gracias por vuestra ayuda.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana

Formula para diferenciar positivo de negativo

Publicado por Antoni Masana (264 intervenciones) el 03/07/2014 07:03:22
La formula:

Para la columna de los positivos: =SI(A1-B1>0; A1-B1; "")

Para la columna de los negativos: =SI(A1-B1<0; A1-B1; "")

Ejemplo 1

1
2
3
4
5
6
7
8
9
10
11
200	420			-220
200	350			-150
200	280			 -80
200	210			 -10
200	203			  -3
200	200
200	192		  8
200	176		 24
200	160		 40
200	 80		120
200	 40		160

Los ceros no te los pondrá en ninguna de las dos columnas, si los quieres en una o en las dos debes añadir un igual en la comparación y si NO quieres la columna en blanco y prefieres un CERO cambia el "" por un CERO ( 0 )

Formula para todas las columnas con números

Para la columna de los positivos: =SI(A1-B1>=0; A1-B1; 0)

Para la columna de los negativos: =SI(A1-B1<=0; A1-B1; 0)

Ejemplo 2

1
2
3
4
5
6
7
8
9
10
11
200	420		  0	-220
200	350		  0	-150
200	280		  0	 -80
200	210		  0	 -10
200	203		  0	  -3
200	200		  0	   0
200	192		  8	   0
200	176		 24	   0
200	160		 40	   0
200	80		120	   0
200	40		160	   0


Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Formula para diferenciar positivo de negativo

Publicado por Mogor (2 intervenciones) el 03/07/2014 12:30:38
Muchisimas gracias Antoni, las formulas perfectas, agradecido.
Un saludo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar