Excel - funcion si

   
Vista:

funcion si

Publicado por agustin logistica@namm.com.mx (3 intervenciones) el 08/09/2014 21:33:34
buen dia...

me podras ayudar en como hacer una funcion para obtrener resultado de los sigueintes datos.

necesito que al seleccionar altura 6 y ducto 12 de como resultado 7.6875 y en el mismo recuadro necesito cuando maqrue altura 8 y ducto 10 de como resultado 11, el primer resultado si lo muestra pero al indicar 8 y 10 marca falso y entre otras leyendas, dejo a continuacion los valores a encontrar..

ALTURA 6
DUCTO12=7.6875
DUCTO14=7.5625
DUCTO16=7.6250
DUCTO18=7.6250

ALTURA 8
DUCTO10=11
DUCTO14=9.75
DUCTO16=9.50
DUCTO18=9.375
DUCTO20=9.50
DUCTO22=9.375
DUCTO24=9.5625

LA FORMULA IMPLEMENTADA ES LA SIGUEINTE.

=SI(E443=6,SI(E444=12,(7.6875),SI(E443=8,SI(E444=10,(11)))))

A PARTIR DEL 3er "SI" MARCA FALSO.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de nolberto

funcion si

Publicado por nolberto (81 intervenciones) el 09/09/2014 18:41:46
Saludos Agustin.

En lugar de anidar muchas veces la funcion si, puedes usar la funcion buscarv para encontrar el resultado en la tabla.

Ejemplo:
=SI(D1=6,BUSCARV(D2,$A$2:$B$5,2,FALSO),BUSCARV(D2,$A$8:$B$14,2,FALSO))

En ese ejemplo puse las dos tablas que contienen los ductos y su valor a partir de la fila A2
En D1 se pone el numero 6 u 8 , en D2 se pone el ducto ( tu lo ajustas a tus referencias )

Con la función si se verifica el dato ( 6 u 8 ), si es 6 , buscarv hace la búsqueda en $A$2:$B$5 , si no es 6, entonces buscara en $A$8:$B$14

En la siguiente pagina puedes ver algo sobre la funcion si
http://formulasexcel.com/funcion-si-de-excel/
En esta puedes ver ejemplo de buscarv
http://formulasexcel.com/funcion-buscarv-en-excel/

suerte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar