Excel - CORRER AUTOMATICAMENTE SUMAR.SI POR FECHA

   
Vista:

CORRER AUTOMATICAMENTE SUMAR.SI POR FECHA

Publicado por Lili llopez@quimerahg.com (3 intervenciones) el 15/11/2014 17:11:27
Como puedo abreviar esta fórmula: =SUMAR.SI('Plan de Operatividad'!$B$10:$B$60,"=11/11/14",'Plan de Operatividad'!$E$10:$E$60)+SUMAR.SI('Plan de Operatividad'!$C$10:$C$60,"=11/11/14",'Plan de Operatividad'!$E$10:$E$60)+SUMAR.SI('Plan de Operatividad'!$D$10:$D$60,"=11/11/14",'Plan de Operatividad'!$E$10:$E$60)+SUMAR.SI('Plan de Operatividad'!$F$10:$F$60,"=11/11/14",'Plan de Operatividad'!$I$10:$I$60)+SUMAR.SI('Plan de Operatividad'!$G$10:$G$60,"=11/11/14",'Plan de Operatividad'!$I$10:$I$60)+SUMAR.SI('Plan de Operatividad'!$H$10:$H$60,"=11/11/14",'Plan de Operatividad'!$I$10:$I$60)+SUMAR.SI('Plan de Operatividad'!$J$10:$J$60,"=11/11/14",'Plan de Operatividad'!$P$10:$P$60)+SUMAR.SI('Plan de Operatividad'!$K$10:$K$60,"=11/11/14",'Plan de Operatividad'!$P$10:$P$60)+SUMAR.SI('Plan de Operatividad'!$L$10:$L$60,"=11/11/14",'Plan de Operatividad'!$P$10:$P$60)+SUMAR.SI('Plan de Operatividad'!$M$10:$M$60,"=11/11/14",'Plan de Operatividad'!$P$10:$P$60)+SUMAR.SI('Plan de Operatividad'!$N$10:$N$60,"=11/11/14",'Plan de Operatividad'!$P$10:$P$60)+SUMAR.SI('Plan de Operatividad'!$O$10:$O$60,"=11/11/14",'Plan de Operatividad'!$P$10:$P$60)+SUMAR.SI('Plan de Operatividad'!$Q$10:$Q$60,"=11/11/14",'Plan de Operatividad'!$T$10:$T$60)+SUMAR.SI('Plan de Operatividad'!$R$10:$R$60,"=11/11/14",'Plan de Operatividad'!$T$10:$T$60)+SUMAR.SI('Plan de Operatividad'!$S$10:$S$60,"=11/11/14",'Plan de Operatividad'!$T$10:$T$60)+SUMAR.SI('Plan de Operatividad'!$Q$10:$Q$60,"=11/11/14",'Plan de Operatividad'!$T$10:$T$60)+SUMAR.SI('Plan de Operatividad'!$U$10:$U$60,"=11/11/14",'Plan de Operatividad'!$V$10:$V$60)+SUMAR.SI('Plan de Operatividad'!$X$10:$X$60,"=11/11/14",'Plan de Operatividad'!$Y$10:$Y$60)+SUMAR.SI('Plan de Operatividad'!$AA$10:$AA$60,"=11/11/14",'Plan de Operatividad'!$AB$10:$AB$60)+SUMAR.SI('Plan de Operatividad'!$AD$10:$AD$60,"=11/11/14",'Plan de Operatividad'!$AC$10:$AC$60)+SUMAR.SI('Plan Mantenimiento'!$B$10:$B$61,"=11/11/14",'Plan Mantenimiento'!$F$10:$F$61)+SUMAR.SI('Plan Mantenimiento'!$C$10:$C$61,"=11/11/14",'Plan Mantenimiento'!$F$10:$F$61).....................................................................................y hacer que corra automaticamente por fecha: 11-nov, 12-nov...etc

Gracias!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de JuanC

CORRER AUTOMATICAMENTE SUMAR.SI POR FECHA

Publicado por JuanC juanc2942@gmail.com (1053 intervenciones) el 15/11/2014 18:05:13
si no entendí mal el problema...
podés poner la fecha en una celda y en la fórmula hacer referencia a ésta...

B1=11/11/14

=SUMAR.SI('Plan de Operatividad'!$B$10:$B$60,"=" & B1, 'Plan de Operatividad'!$E$10:$E$60) + .....

Saludos, desde Baires, JuanC
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar

CORRER AUTOMATICAMENTE SUMAR.SI POR FECHA

Publicado por Lili (3 intervenciones) el 16/11/2014 08:57:18
...,"=" & B1,... ----------------> no sabia como definir ese criterio
Mil gracias Juan!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Nolberto

CORRER AUTOMATICAMENTE SUMAR.SI POR FECHA

Publicado por Nolberto (81 intervenciones) el 15/11/2014 18:36:01
Tal parece que el problema esta en la estructura de tu base de datos, aunque no puedo estar seguro puesto porque no hay detalles al respecto.

En la mayoría de los casos, el no estructurar correctamente la tabla, provoca muchos problemas a la hora de generar reportes.

En la siguiente pagina se explica como calcular existencias de almacén, y precisamente se explica algo sobre la forma correcta de estructurar las tablas o bases de datos, también se usa la funcion SUMAPRODUCTO, que en tu caso puedes usar para sustituir SUMAR.SI y de ese modo simplificar la formula.
http://formulasexcel.com/curso-de-excel-formula-para-calcular-existencias/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar

CORRER AUTOMATICAMENTE SUMAR.SI POR FECHA

Publicado por Lili (3 intervenciones) el 16/11/2014 09:05:45
Gracias Nolberto, en realidad se trata de contabilizar la cantidad de personas que trabajan por fecha, y controlar la carga laboral,
Gracias por la información! me es muy útil!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar