Excel - confección de formula

   
Vista:

confección de formula

Publicado por MTK (13 intervenciones) el 29/11/2014 19:00:47
Si tengo la siguiente formula:

=SI((SUMA(E11;H11)>I3); SUMA(E11;H11)/24; SUMA(E11;H11))


donde I3 es 00:59:99 y donde E11 es 00:29:28 y H11 es 00:39:00 y quiero que me de como resultado 01:08:28 (1minuto con 8 segundos y 28 centesimas) , QUE TENGO QUE CORREGIR EN LA FORMULA? Gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

confección de formula

Publicado por Martha (270 intervenciones) el 30/11/2014 20:07:10
Hasta dónde yo sé el formato Hora de Excel es hh:mm:ss por tanto lo que tienes son horas, minutos y segundos, no minutos segundos y centésimas, por tanto I3 nunca te podrá valer 00:59:99 porque un instante después de 00:59:59 la celda valdrá 01:00:00.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

confección de formula

Publicado por MTK (13 intervenciones) el 30/11/2014 21:29:43
Gracias por responder Martha, pero no es así ya que el formato dado a la celda es 00H\:00\:00\:00 horasH:minutos:segundos:centesimas que es lo que utilizo para tiempos con mas precisión que los segundos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de Jose

confección de formula

Publicado por Jose (5 intervenciones) el 30/11/2014 23:32:05
Hola MTK

Aunque tengas el formato de hora, Excel lee los minutos que introduzcas como una parte proporcional de un día de 24 horas, por ejemplo, si pones 6 horas (6:00:00) para excel es 0,25 (la cuarta parte de 24).

Pero probando tu fórmula, veo que está correcta, te da el resultado que pides: que si La suma de E11:H11 (1:08:28) es mayor que I3 (0:59:00) el resultado sea SUMA(E11;H11)/24 = 0:02:51.

Si corriges y quitas la división entre 24, te da 01:08:28.

No se si esto te aclare, pero si no, coméntame ¿qué buscas dividiendo entre 24? y quizás te pueda ayudar.

Un saludo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

confección de formula

Publicado por MTK (13 intervenciones) el 01/12/2014 00:24:55
Hola Jose, gracias por responder...Primero aclaro que no soy un experto en esto. La verdad que no se que busco dividiendo por 24, entre pruebas y errores quedo 24 que me da un mal resultado....El problema es que sumando E11 mas H11 me da como resultado 00:68:28, osea 68seg con 28 centésimas y yo necesito que el resultado salga expresado en 01:08:28 osea 1min08seg28centesimas y no se porque al pasar de 00:59:99 no me pone el resultado como 1min con los seg y cent que correspondan
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

confección de formula

Publicado por MTK (13 intervenciones) el 01/12/2014 04:01:46
Aquí esta la solución:

=C5+F5+SI(C5+F5>5999,4000,0)

Gracias a todos!!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar