Excel - buscar el menor valor con 2 condiciones

   
Vista:

buscar el menor valor con 2 condiciones

Publicado por juan (1 intervención) el 14/05/2015 21:13:07
Hola que tal

Agradesco la ayuda de ante mano,

como podria:

obtener el menor valor de un columna A que sea mayor a 0 , considerando los renglones de la columna B que = "si"

{=MIN(SI(a1:a100>0,b1:b100="si"))}
utilizo esta formula matricial pero no me funciona,

Si utilizo la siguiente si funciona pero falta el criterio ="si"
{=MIN(SI(a1:a100>0,b1:b100))}

NOrmalmente lo hago realizado calculos en otras 4 columnas para conseguirlo pero alguien tiene o sabe
Alguna idea para realizarlo con 1 formula y evitar 4 columnas de calculos ?

Muchas gracias
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder

buscar el menor valor con 2 condiciones

Publicado por Jesus (2 intervenciones) el 15/05/2015 17:26:53
Que tal Juan,

La verdad no se como resolverlo con una formula.

Pero si tal vez con una sola columna de ayuda.

Si tus únicas condiciones que tienes en la columna B, es Si o No, a "No" le colocaría un número enorme, es y lo sumaria al de la columna A. Es decir:

=SI(A1="Si",0,1000)+A1

y de ahí partiría para buscar el mínimo de esa matriz.

Espero te ayude.

Saludos.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

buscar el menor valor con 2 condiciones

Publicado por Juanjo (494 intervenciones) el 20/05/2015 08:18:41
Muy buenas.

Pues utilizando esta fórmula matricial te puede servir:
{=MIN(SI(A1:A100>0;A1:A100;1000000)*SI(B1:B100="si";1;1000000))}

Posiblemente tengas que cambiar los ";" por ","

Un saludo. Juanjo.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar