Excel - Cambiar Texto de una Celda segun el Valor de otra

   
Vista:

Cambiar Texto de una Celda segun el Valor de otra

Publicado por Carlos Murillo (2 intervenciones) el 19/07/2015 19:35:55
Buenos Dias tengo un problema con una funcion en Excel a ver si alguien me haria el favor de hecharme una mano

Tengo la columna Z que contiene ''poderes'' fuego hielo electrico y tierra, necesito que dicha columna cambie de texto (de esas 3 opciones) segun el valor de la columna A supongamos

184= Fuego
186= Electrico
190= Hielo
Diferentes de los anteriores = Tierra

Les paso la funcion que hasta ahora no me manda error use la funcion =SI()

=SI(A4=184,"Fuego",Z4)

De esa forma si el valor de la celda A4 es 184 el texto de la celda Z4 cambia a ''Fuego'' he aqui el problema, intente anidar mas funciones SI para que me hiciera las 3 comparaciones en la misma celda algo asi

=SI(A4=184,"Planta",Z4 SI(A4=186,"Electrico",Z4))

Pero ahi parece que tengo error de sintaxis me tira error !VALOR


Mencionar que soy nuevo en esto de excel lo que fui aprendiendo fue por tutoriales

Muchas gracias anticipadas!
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Andres Leonardo

Cambiar Texto de una Celda segun el Valor de otra

Publicado por Andres Leonardo (491 intervenciones) el 20/07/2015 04:19:06
Espero te sirva el ejemplo

Lo si te sirven pero si es mas de 4 si te volveras loco...

Utiliza una base alterna y buscalo .. te adjunto ejemplo
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
2
Comentar

Cambiar Texto de una Celda segun el Valor de otra

Publicado por Carlos Murillo (2 intervenciones) el 20/07/2015 04:47:06
Te lo agradezco mucho Andres, no sabia que existia esa variante de la funcion SI


Te debo una!

Bonita tarde!
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
1
Comentar
Imágen de perfil de Andres Leonardo

Cambiar Texto de una Celda segun el Valor de otra

Publicado por Andres Leonardo (491 intervenciones) el 20/07/2015 20:39:25
De nada lo importante es que te sirva lo entiendas y claro lo hayas aprendido

Saludos desde Ecuador
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Cambiar Texto de una Celda segun el Valor de otra

Publicado por Paul Santillan (1 intervención) el 07/02/2016 07:21:46
Muchas Gracias, ya me estaba dando por vencido, me parecia imposible jejejeje....
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Cambiar Texto de una Celda segun el Valor de otra

Publicado por William (1 intervención) el 07/12/2015 17:35:02
Esto lo hace en las celdas de colomna Z donde quiere obtener este resultado.
=si(a1=184;"fuego";si(a1=186;"electrico";si(a1=190;"hielo")))

Si quiere poner mas condiciones puede hacerlo. Un ejemplo:
=si(a1=184;"fuego";si(a1=186;"electrico";si(a1=190;"hielo";si(a1=174;"tornado";si(a1=205;"fuerza")))))
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Cambiar Texto de una Celda segun el Valor de otra

Publicado por Alberto (1 intervención) el 12/03/2016 09:04:35
Hola
Estoy utilizando la misma formula pero en vez de = (igual que) pongo > (mayor que), pero no me funciona y sólo me coge el primer valor (=IF(C5>100;) de la fórmula =IF(C5>100;"B1";IF(C5>200;"B2";IF(C5>300;"B3";IF(C5>400;"C1";IF(C5>500;"C2"))))) y al superar los valores insertados en la celda C5 se siguen quedando en el primer valor que es >100.

Qué se puede hacer? Muchas gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Cambiar Texto de una Celda segun el Valor de otra

Publicado por SANTIAGO (1 intervención) el 15/03/2016 22:20:20
Hola Alberto
Para que funcione la funcion debes establecer rangos por ejemplo =if(c5<=200;"b1";IF(C5<=300;"B3"))......y asi hasta lo que necesitas.
Saludos
Espero haber podido ayudarte
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar
Imágen de perfil de wordexperto.com

Cambiar Texto de una Celda segun el Valor de otra

Publicado por wordexperto.com (496 intervenciones) el 21/08/2016 20:15:58
Hola a todos:
No es conveniente utilizar la función Si para más de tres opciones, se vuelve muy compleja y difícil de detectar los errores. Para estos casos, más de tres condiciones, es mejor utilizar buscarv o indice+coincidir.
https://wordexperto.com/blog/
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

Cambiar Texto de una Celda segun el Valor de otra

Publicado por Alfredo (1 intervención) el 21/08/2016 18:19:03
Vi las respuestas anteriores y solo falto la opción "Tierra", la cual era que si no cumplía ninguna de las tres condiciones, la supliera con esa opción. Esa opción se agrega en la última función SI(). Si quieres mas comparaciones puedes hacerlas pero siempre debes agregar el último DATO que no cumpla las comparaciones anteriores, en la última función SI().

La fórmula es la siguiente:

=SI($A4=184;"Fuego";SI($A4=186;"Eléctrico";SI($A4=190;"Hielo";"Tierra")))

---------------------------------------------------------------------------------------------------------
Tu problema según el ejemplo que diste fue:
=SI(A4=184,"Planta",Z4 SI(A4=186,"Electrico",Z4))

y es:
=SI(A4=184,"Planta",SI(A4=186,"Electrico","Tierra"))
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar