Excel - extrae números con decimales acabados en 0

   
Vista:

extrae números con decimales acabados en 0

Publicado por Pedro (6 intervenciones) el 19/04/2016 01:45:18
Hola!
Mi pregunta es la siguiente:
Tengo puesta una fórmula para que me extraiga los dígitos de un número celda a celda, el problema es que cuando los decimales del número acaban en 0 ó 00, me desplazan los digitos a la derecha en lugar que poner esos ceros.
Los números deben tener siempre 2 decimales.
Por si no me explico bien, os dejo un ejemplo para que lo veáis.
Valora esta pregunta
Me gusta: Está pregunta es útil y esta claraNo me gusta: Está pregunta no esta clara o no es útil
0
Responder
Imágen de perfil de Antoni Masana

extrae números con decimales acabados en 0

Publicado por Antoni Masana (268 intervenciones) el 19/04/2016 07:32:03
Copia cada una de las formulas en la celda correspondiente y selecciona desde G5 hasta K5 y arrastras hacia abajo y ya esta.


1
2
3
4
5
Celda G5   =EXTRAE(DERECHA(CONCATENAR("  ";TEXTO($D1;"0.00"));6);1;1)
Celda H5   =EXTRAE(DERECHA(CONCATENAR("  ";TEXTO($D1;"0.00"));6);2;1)
Celda I5   =EXTRAE(DERECHA(CONCATENAR("  ";TEXTO($D1;"0.00"));6);3;1)
Celda J5   =EXTRAE(DERECHA(CONCATENAR("  ";TEXTO($D1;"0.00"));6);5;1)
Celda K5   =EXTRAE(DERECHA(CONCATENAR("  ";TEXTO($D1;"0.00"));6);6;1)

Se realizan tres pasos antes de extraer el carácter:

1.- TEXTO convierte el número en texto.
2.- CONCATERNAR - añade 2 espacios a la izquierda para números menores de 10
3.- DERECHA - extrae los 6 primeros caracteres de la derecha.

Y a partir de aquí tenemos que el 1 se convierte en esta bonita cadena de texto " 1.00" y el resto es facil

1
"  1.00"

Saludos
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

extrae números con decimales acabados en 0

Publicado por Pedro (6 intervenciones) el 19/04/2016 16:10:00
Gracias, lo probaré.
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

extrae números con decimales acabados en 0

Publicado por Pedro (6 intervenciones) el 19/04/2016 18:02:49
No me funciona, pero le daré vueltas a eso de convertir en texto.
Gracias
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar

extrae números con decimales acabados en 0

Publicado por Pedro (6 intervenciones) el 19/04/2016 18:36:46
La solución perfecta es cambiar la fórmula de D1 por esta =TEXTO(A1*B1;"0,00")
Gracias de todas formas Antoni Masana
Valora esta respuesta
Me gusta: Está respuesta es útil y esta claraNo me gusta: Está respuesta no esta clara o no es útil
0
Comentar