Utilizamos cookies propias y de terceros para mejorar la experiencia de navegación, y ofrecer contenidos y publicidad de interés.
Al continuar con la navegación entendemos que se acepta nuestra política de cookies.
Iniciar sesión Cerrar
Correo:
Contraseña:
Entrar
Recordar sesión en este navegador
Crear cuenta

Excel - Contar dígitos en excel

Vista:
Me gusta: Está pregunta es útil y esta clara
0
No me gusta: Está pregunta no esta clara o no es útil
 
Asunto:Contar dígitos en excel
Autor:Manuel Angel Valcárcel Rodrígu (12 intervenciones)
Fecha:05/05/2006 13:20:50
Tengo una columna de excel con numeros de 2 a 5 dígitos, necesitaría contar el nº de dígitos individualmente, es decir por ejemplo cuantos unos, dos, tres...existen en toda la columna.
Responder Subir
información
Otras secciones de LWP con contenido similar...
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:Contar dígitos en excel
Autor:JuanC (792 intervenciones)
Fecha:05/05/2006 13:53:29
Esta es una versión "rebuscada" si se quiere, pero efectiva!
Lo ideal es hacerlo con una macro... eso es otra historia...

Seleccionar todo, copiar y pegar en bloc de notas para verlo bien...

A B C D E F G
1
2 Nº
3 1 "=EXTRAE(B3;1;1)" "=EXTRAE(B3;2;1)" "=EXTRAE(B3;3;1)" "=EXTRAE(B3;4;1)" "=EXTRAE(B3;5;1)"
4 23 "=EXTRAE(B4;1;1)" "=EXTRAE(B4;2;1)" "=EXTRAE(B4;3;1)" "=EXTRAE(B4;4;1)" "=EXTRAE(B4;5;1)"
5 450 "=EXTRAE(B5;1;1)" "=EXTRAE(B5;2;1)" "=EXTRAE(B5;3;1)" "=EXTRAE(B5;4;1)" "=EXTRAE(B5;5;1)"
6 52 "=EXTRAE(B6;1;1)" "=EXTRAE(B6;2;1)" "=EXTRAE(B6;3;1)" "=EXTRAE(B6;4;1)" "=EXTRAE(B6;5;1)"
7 123 "=EXTRAE(B7;1;1)" "=EXTRAE(B7;2;1)" "=EXTRAE(B7;3;1)" "=EXTRAE(B7;4;1)" "=EXTRAE(B7;5;1)"
8 265 "=EXTRAE(B8;1;1)" "=EXTRAE(B8;2;1)" "=EXTRAE(B8;3;1)" "=EXTRAE(B8;4;1)" "=EXTRAE(B8;5;1)"
9 65541 "=EXTRAE(B9;1;1)" "=EXTRAE(B9;2;1)" "=EXTRAE(B9;3;1)" "=EXTRAE(B9;4;1)" "=EXTRAE(B9;5;1)"
10 2 "=EXTRAE(B10;1;1)" "=EXTRAE(B10;2;1)" "=EXTRAE(B10;3;1)" "=EXTRAE(B10;4;1)" "=EXTRAE(B10;5;1)"
11 987 "=EXTRAE(B11;1;1)" "=EXTRAE(B11;2;1)" "=EXTRAE(B11;3;1)" "=EXTRAE(B11;4;1)" "=EXTRAE(B11;5;1)"
12
13 0 1 2 3 4 5 6 7 8 9
14 "=CONTAR.SI($C$3:$G$11;0)" "=CONTAR.SI($C$3:$G$11;1)" "=CONTAR.SI($C$3:$G$11;2)" "=CONTAR.SI($C$3:$G$11;3)" "=CONTAR.SI($C$3:$G$11;4)" "=CONTAR.SI($C$3:$G$11;5)" "=CONTAR.SI($C$3:$G$11;6)" "=CONTAR.SI($C$3:$G$11;7)" "=CONTAR.SI($C$3:$G$11;8)" "=CONTAR.SI($C$3:$G$11;9)"
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:Contar dígitos en excel
Autor:Manuel V. (12 intervenciones)
Fecha:08/05/2006 10:26:23
No comprendo la solución apuntada por Juanc. Si se puede explicar un poco más, gracias.
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:Contar dígitos en excel
Autor:Mark (273 intervenciones)
Fecha:11/05/2006 02:30:53
Estimado Manuel el ejemplo que te expone JuanC esta clarisimo, aunque bastante rebuscado como el mismo lo expone pero funcional y coincido con él en hacerlo desde macros, aunque tal vez desde excel sale, pero yo siempre me inclino por VBA es cuestion de costumbre; en cuanto al post de JuanC creo no sabes interpretar lo que el te publica, sin embargo ya te he enviado al e-mail, pues veo que me has realizado la misma consulta por esa via, el ejemplo en una hoja de calculo , pero te digo que deberas escribir bastante si tienes muchos datos lo digo por lo de las referencias, asi que te recomiendo macros

Saludos...
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:Contar dígitos en excel
Autor:Manuel Angel Valcarcel (12 intervenciones)
Fecha:11/05/2006 07:31:16
Muchas gracias Mark, entendido. Saludos
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:Contar dígitos en excel
Autor:Claudio (1 intervención)
Fecha:30/10/2006 19:59:11
si solo tenes celdas con 5 digitos como maximo, usa la funcion "+contar()". Mas facil imposible.
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:Contar dígitos en excel
Autor:SFLR (3 intervenciones)
Fecha:01/01/2011 21:20:54
Por favor, pero de verdad no hay nadie que pueda ayudarme a solucionar este problema, al menos mediante excel:
SUPONGA QUE TIENE QUE ESCRIBIR LOS NUMEROS DESDE 1 HASTA UN MILLON. ¿CUANTOS CEROS HABRA ESCRITO?
Gracias
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:Contar dígitos en excel
Autor:Cantabru (2 intervenciones)
Fecha:23/04/2010 12:51:36
=largo(celda)
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:RE:Contar dígitos en excel
Autor:Manrique (1 intervención)
Fecha:20/05/2010 16:47:34
En excel puedes usar la formula LEN(A1) para contar los digitos de una celda, ejemplo la celda A1.
Espero que te resulte
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:Pregunta
Autor:Antonio (1 intervención)
Fecha:03/12/2010 22:59:20
Hola a todos,

tengo un problema con unos datos en excel:
La cuestion es que me llegan datos como estos 100- , 38-, 69-, etc. a algunas celdas. Yo necesito convertir ese numero en negativo, pero obviamente no me deja ya que aparece como texto, cómo hago para sacar el número y borrar el signo (-) que aparece al final.

Mil gracias por su colaboracion.
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:Contar dígitos en excel
Autor:julio flifly186@yahoo.es (1 intervención)
Fecha:29/02/2012 16:54:13
utiliza la funcion largo. ejem

=LARGO(F2) esta funcion te dara cuantos digitos tienes en una celda
Comentar Subir
Me gusta: Está respuesta es útil y esta clara
0
No me gusta: Está respuesta no esta clara o no es útil
 
Asunto:Contar dígitos en excel
Autor:Angie (1 intervención)
Fecha:01/06/2012 00:46:25
Muchas Gracias por su ayuda
Comentar Subir